Posted on August 4, 2015 7:02 pm
 |  Asked by prasanna siriki
 |  1068 views
RESOLVED
0
0
Print Friendly, PDF & Email

Hi,

Iam trying to configure Arista Eos Swith through ansible.eos.

getting the below error while runing the playbook.

Error:eos_vlan is not a legal parameter in an Ansible task or handler.

Attached the error file

Regards,

Psiriki

 

Attachments:
0
Posted by ma
Answered on August 4, 2015 8:12 pm

Hi Psiriki,

Most likely you’re getting the error, because Ansible can’t find the eos_vlan library.
Have you followed the following procedure to install the Ansible EOS Role:
http://ansible-eos.readthedocs.org/en/master/install.html#install-the-ansible-eos-role

What if you issue the following:
sudo find / -name eos_vlan.py

Kind regards,
-Michael

Hi Michael,
I installed ansible-eos from https://github.com/arista-eosplus/ansible-eos
Created the softlink. to the /etc/ansible/roles

Attached the error file.
Regards,
Psiriki

(prasanna siriki at August 4, 2015 9:38 pm)
0
Posted by Philip DiLeo
Answered on August 5, 2015 1:15 pm

Hi Psiriki,

I noticed from your .doc log above that the current working directory is called ansible-eos. A few things to note:

  1. If this is the git clone of the ansible-eos github repo it is recommended that you do not place your local playbooks within this directory.  If you do not plan to develop ansible-eos modules then you can install the Ansible Role for EOS by using the ansible-galaxy command documented here. This is the easier, simpler method.
  2. If you intend to do custom module development and want to closely follow the github develop branch then you can make the role available to any playbook by following the steps here.

If you have any trouble please feel free to reach out to the specific ansible mailing list ansible-dev@arista.com.

Best,

PD

0
Posted by Johann Lo
Answered on April 28, 2016 2:11 am

I’ve got the same problem and its driving me crazy.

I used the galaxy method and it installed fine, but I’m getting the same error

ERROR: eos_vlan is not a legal parameter in an Ansible task or handler

I’m calling the role in my playbook

- name: eos nodes
hosts: spine_switches
connection: local

roles:
– arista.eos

tasks:
– name: Configure EOS VLAN resources
eos_vlan: vlanid=100
name=mynewamazingvlan100
host={{ inventory_hostname }}
username={{ username }}
password={{ password }}
transport={{ transport }}

the module is found with the find command as well…

root@unl01:/# sudo find / -name eos_vlan.py
/etc/ansible/roles/arista.eos/library/eos_vlan.py

 

At a loss here, would super appreciate some assistance

Hi Johann! Just replied to your mail at ansible-dev@. Happy to help! Likely your issue is that you’re running Ansible version < 1.9, but we can troubleshoot further if that’s not the case.
Best

(Philip DiLeo at April 28, 2016 12:07 pm)

Post your Answer

You must be logged in to post an answer.