Posted on June 10, 2020 12:23 pm
 |  Asked by Gualter Fernandes
 |  61 views
RESOLVED
0
0
Print Friendly, PDF & Email

Hi,

I am getting the following error when I try run the commands to enable the api.

Some one can help me here?

https://img.nbits.io/RBuq7pxd

G08N01(config)#management api http-commands

% Invalid input

 

 

What should I do?

 

thanks

0
Posted by Tamas Plugor
Answered on June 10, 2020 12:27 pm

What EOS version are you running? eAPI has been introduced in 4.12, and that device's max supported version is 4.13.x (first unsupported version is 4.14.0),if it's the 7048TA version that has first unsupported version of 4.16.6. FYI these have been end of life for a few years now, so you are probably running a very old EOS version

Arista EOS 4.9.8.1
(Gualter Fernandes at June 10, 2020 1:29 pm)
0
Answered on June 10, 2020 7:26 pm

Hi Gualter.

As mentioned by Tamas, eAPI support was introduced in EOS 4.12, therefore, EOS 4.9.8.1 will not have this option available, unfortunately.

Post your Answer

You must be logged in to post an answer.