Posted on March 11, 2019 8:21 pm
 |  Asked by Mikiko Anhoco
 |  78 views
Tags:
0
0
Print Friendly, PDF & Email

So I just got my new, shiny 7124S today. First thing I did was to factory-reset the switch and apply the fan override commands. Those worked perfectly.

I then tried to follow this guide to get it set up with basic L3 inter-VLAN routing. However, when I go into the config and tried setting the IP, here’s what I got:

XGCore(config-if-Et1)#ip address 172.16.254.2/24
% Invalid Input
What might be wrong here? (Let’s just say I’m very new to EOS, and I’ve never really configured IOS either. Most of my experience is on JunOS, so it might be a simple thing that I’ve overlooked)

EDIT: oh, and also, is there a way to make the fans go lower than 30%?

EDIT 2: turns out that the problem comes from the ancient version of EOS running on there. Upgraded and now it’s working just as expected.

0
Answered on March 12, 2019 3:55 am

Hi Mikiko,

The product 7124 is End of life. Please refer to the link below for more details:
https://www.arista.com/en/support/advisories-notices/end-of-sale/627-end-of-sale-7124sx

The invalid input could be due to an unsupported EOS version on the device. The first unsupported release for this platform is 4.14.0.

Could you please confirm if the device is running any EOS version after 4.14.0?

Following is the recommendation regarding the fans:
The environment fan-speed command determines the method of controlling the speed of the switch
fans. The switch automatically controls the fan speed by default.
The switch normally controls the fan speed to maintain optimal operating temperatures. The fans can
be configured to operate at a constant speed regardless of the switch temperature conditions.
The no environment fan-speed and default environment fan-speed commands restore the default
action of automatic fan-speed control by removing the environment fan-speed override statement
from running-config.

Please refer to the link below for more details: https://www.arista.com/en/um-eos/eos-switch-environment-control

Thank you.

1
Posted by Naveen Chandra
Answered on March 17, 2019 2:47 pm

Hi Mikiko,

Did you make interface Ethernet1 a L3 interface by issuing “no switchport” command? Also give a try by configuring the IP address with netmask, as below.

XGCore(config-if-Et1)#no switchport
XGCore(config-if-Et1)#ip address 172.16.254.2 255.255.255.0

Post your Answer

You must be logged in to post an answer.