Posted on January 11, 2017 3:34 am
 |  Asked by Steve Vernau
 |  1462 views
0
0
Print Friendly, PDF & Email

I know with arista all VRF’s have to have the same AS number. lets say I use as 65000 to ebgp peer with someone.

If I set up aanother VRF and want to ibgp peer with someone using as 65005, with the “local as” function where you impersonate an AS number, if I use local-as 65005 and peer with another router using 65005 will it behave as iBGP? Because I have an arista router using 65000 for eBGP with a partner and I need to also iBGP with someone using 65005 in a second VRF. Will this local-as approach work?

 

Really need a solution.

0
Posted by John Frame
Answered on January 11, 2017 7:18 pm

Hi Steve,

Yes, you can absolutely do what you are intending here, and you are on the right track. ¬†Here’s an example to show.

sw1: ebgp 65001 to sw2 in default vrf
sw2: ibgp 65005 to sw3 in default vrf
sw3: ebgp 65000 to sw1 in default vrf, ibgp 65005 to sw2 in vrf “IBGP”

Below is the relevant config for each and the resulting outputs.

SW1:

sw1(config)#show run sec bgp
router bgp 65001
neighbor EBGP peer-group
neighbor EBGP remote-as 65000
neighbor EBGP maximum-routes 12000
neighbor 10.0.1.3 peer-group EBGP

sw1(config)#sh ip bgp sum
BGP summary information for VRF default
Router identifier 10.0.1.1, local AS number 65001
Neighbor Status Codes: m – Under maintenance
Neighbor V AS MsgRcvd MsgSent InQ OutQ Up/Down State PfxRcd PfxAcc
10.0.1.3 4 65000 22 22 0 0 00:18:26 Estab 0 0

SW2:

sw2(config)#show run sec bgp
router bgp 65005
neighbor IBGP peer-group
neighbor IBGP remote-as 65005
neighbor IBGP maximum-routes 12000
neighbor 10.0.2.3 peer-group IBGP

sw2(config)#sh ip bgp sum
BGP summary information for VRF default
Router identifier 10.0.0.2, local AS number 65005
Neighbor Status Codes: m – Under maintenance
Neighbor V AS MsgRcvd MsgSent InQ OutQ Up/Down State PfxRcd PfxAcc
10.0.2.3 4 65005 14 15 0 0 00:10:20 Estab 0 0

SW3:

sw3(config)#show run sec bgp
vrf definition IBGP
rd 65005:1
!
interface Ethernet3
load-interval 5
no switchport
vrf forwarding IBGP
ip address 10.0.2.3/24
!
ip routing vrf IBGP
!
router bgp 65000
neighbor EBGP peer-group
neighbor EBGP remote-as 65001
neighbor EBGP maximum-routes 12000
neighbor IBGP peer-group
neighbor IBGP remote-as 65005
neighbor IBGP maximum-routes 12000
neighbor 10.0.1.1 peer-group EBGP
vrf IBGP
local-as 65005
neighbor 10.0.2.2 peer-group IBGP

sw3(config)#show ip bgp neighbors 10.0.1.1
BGP neighbor is 10.0.1.1, remote AS 65001, external link
BGP version 4, remote router ID 10.0.1.1, VRF default

sw3(config)#show ip bgp neighbors 10.0.2.2 vrf IBGP
BGP neighbor is 10.0.2.2, remote AS 65005, internal link
BGP version 4, remote router ID 10.0.0.2, VRF IBGP

sw3(config)#show ip bgp sum
BGP summary information for VRF default
Router identifier 10.6.6.6, local AS number 65000
Neighbor Status Codes: m – Under maintenance
Neighbor V AS MsgRcvd MsgSent InQ OutQ Up/Down State PfxRcd PfxAcc
10.0.1.1 4 65001 35 35 0 0 00:31:52 Estab 0 0

sw3(config)#show ip bgp sum vrf IBGP
BGP summary information for VRF IBGP
Router identifier 10.0.2.3, local AS number 65005
Neighbor Status Codes: m – Under maintenance
Neighbor V AS MsgRcvd MsgSent InQ OutQ Up/Down State PfxRcd PfxAcc
10.0.2.2 4 65005 25 25 0 0 00:21:54 Estab 0 0

 

So just to be sure, will ibgp only transitive attributes like local preference be present in the bgp updates sent over a masqueraded ibgp peer link? Ie it will fully behave as ibgp and not strip off ibgp only info from the updates?

(Steve Vernau at March 14, 2017 7:50 am)

Post your Answer

You must be logged in to post an answer.