Posted on March 22, 2021 3:53 am
 |  Asked by Gabor Ivanszky
 |  40 views
0
0
Print Friendly, PDF & Email

Hi,

 

we realized that we have non-intended ECMP on a DCS-7060CX-32S because of BGP path only different in their cluster list length.

We have added the “bgp bestpath tie-break cluster-list-length”, did a soft BGP reset, but the situation is the same. Should we do anything else to active the “bgp bestpath tie-break cluster-list-length” setting?

 

* >Ec 2.58.168.0/22 217.113.61.226 0 160 0 42864 ?
* ec 2.58.168.0/22 217.113.61.56 0 160 0 42864 ? Or-ID: 217.113.61.224 C-LST: 217.113.61.188
* >Ec 5.56.32.0/24 217.113.61.226 0 160 0 41075 i
* ec 5.56.32.0/24 217.113.61.56 0 160 0 41075 i Or-ID: 217.113.61.224 C-LST: 217.113.61.188
* >Ec 5.56.39.0/24 217.113.61.226 0 160 0 41075 i
* ec 5.56.39.0/24 217.113.61.56 0 160 0 41075 i Or-ID: 217.113.61.224 C-LST: 217.113.61.188

0
Posted by Naveen Chandra
Answered on March 25, 2021 3:08 am

Hi Gabor,

Thanks for posting in this forum. While seeing the output you have shared, it looks like the ECMP is enabled (“maximum-paths†value is more than 1) under router bgp in your device. Could you please check and confirm the same?

If yes, you would like to make it default "default maximum-paths".

Also could you please let me know the Arista Platform and EoS version you are using? Please also find the below document explaining the BGP best-path selection algorithm in detail.

https://eos.arista.com/eos-4-25-0f/bgp-best-path/

Post your Answer

You must be logged in to post an answer.