Posted on May 24, 2019 5:24 pm
 |  Asked by Aftab Siddiqui
 |  289 views
0
0
Print Friendly, PDF & Email

I have a network setup with 6 Arista 7050QX running VXLAN-EVPN. All nodes are doing eBGP. I can establish eBGP sessions and configure EVPN as well but the moment I start sending traffic via VXLAN then BGP stops working saying “BGP agent not running”.

I have tried 4.21.5F, 4.21.3F and currently using 4.20.5F but same result.

Config looks like this at one end.

Router bgp 65001

vlan 101
rd 10.61.0.7:101
route-target both 101:10000002
redistribute learned

interface Vxlan1
description VXLAN Interface
vxlan source-interface Loopback0
vxlan udp-port 4789
vxlan vlan 100 vni 10000001
vxlan vlan 101 vni 10000002

Arista DCS-7050QX-32-R
Hardware version: 02.11
Serial number: xx
System MAC address: xx

Software image version: 4.20.5F
Architecture: i386
Internal build version: 4.20.5F-8127914.4205F
Internal build ID: 311c887d-d677-4f60-97dd-54e4ef202868

Uptime: 2 days, 11 hours and 48 minutes
Total memory: 3956120 kB
Free memory: 2349256 kB

Remote configuration is identical with different VLAN mapping.

interface Vxlan1
description VXLAN Interface
vxlan source-interface Loopback0
vxlan udp-port 4789
vxlan vlan 100 vni 10000000
vxlan vlan 101 vni 10000001
vxlan vlan 102 vni 10000002

router bgp 65000

vlan 102
rd 10.61.0.1:102
route-target both 102:10000002
redistribute learned

0
Posted by Aesha Parikh
Answered on May 24, 2019 5:39 pm

Hi Aftab,

Can you ensure you are running multi-agent protocol? If not, you should configure below command for EVPN support:

service routing protocols model multi-agent

Please note this will restart your routing agent which means your bgp sessions will terminate and reestablish.

Thanks,
Aesha

0
Posted by Jose Reyes
Answered on May 24, 2019 7:06 pm

Hi Aftab.

As Aesha stated, most likely you are missing multi-agent configuration. As per this doc: https://eos.arista.com/evpn-configuration-layer-2-evpn-design-with-type-2-routes/

The EVPN BGP functionality is provided by a new BGP agent, therefore before configuring any eBGP functionality for either the underlay or overlay networks on the leaf or spine switches, the new BGP agent needs to enabled on each of the switches with the command below:

CLI command to enable EVPN BGP agent on the Leaf and Spine nodes

“service routing protocols model multi-agent”

Hope that helps.

0
Posted by Aftab Siddiqui
Answered on May 27, 2019 5:39 pm

Hi Jose and Aesha,
“service routing protocols model multi-agent” is already there but thanks for pointing it out. Another point I just want to clarify. The physical connectivity between 2 switches is via a third party providing single VLAN so the connectivity is over SVI. Does it make any difference?

0
Posted by James Greig
Answered on May 31, 2019 1:42 pm

Hi,

This may not be of much help to you. However, there are a number of known bugs in arBGP, i’d suggest upgrading in my opinion. I used arBGP (multi-agent) and suffered numerous crashes which resulted in a couple of fixes being pushed out by the EOS team. EOS 4.21.3F and up fixed a number of headaches for me.

James

0
Posted by Alex
Answered on May 31, 2019 5:43 pm

Hi Aftab, you are testing on a 7050X platform which requires the re-circulation ports to be configured to support VXLAN routing. The details are covered here…

https://eos.arista.com/eos-4-15-2f/unconnected-ethernet/

If the re-circulation ports are configured can you send the output of the following commands:

show interface vxlan 1
show ip bgp summary
show bgp epvn summary
show bgp evpn route-type mac-ip detail
show bgp evpn route-type ip-prefix detail

Alex

Post your Answer

You must be logged in to post an answer.