Posted on October 17, 2019 9:52 pm
 |  Asked by Hairul Redzuan Saring
 |  167 views
RESOLVED
1
0
Print Friendly, PDF & Email

I configured iBGP between Arista and Cisco devices, using OSPF as an IGP. I’m getting the full BGP prefixes from the neighbor, but the default route is showing “# – not installed”.

arista#sh ip bgp neigh x.x.x.x received-routes
BGP routing table information for VRF default
Route status codes: s – suppressed, * – valid, > – active, # – not installed, E – ECMP head, e – ECMP
S – Stale, c – Contributing to ECMP, b – backup, L – labeled-unicast
Origin codes: i – IGP, e – EGP, ? – incomplete
AS Path Attributes: Or-ID – Originator ID, C-LST – Cluster List, LL Nexthop – Link Local Nexthop

Network Next Hop Metric LocPref Weight Path
* # 0.0.0.0/0 x.x.x.x 0 100 – AAAA i
* 10.1.40.0/21 x.x.x.x – 100 – BBBB CCCC ?

Arista#sh ip ro 0.0.0.0
VRF: default
Codes: C – connected, S – static, K – kernel,
O – OSPF, IA – OSPF inter area, E1 – OSPF external type 1,
E2 – OSPF external type 2, N1 – OSPF NSSA external type 1,
N2 – OSPF NSSA external type2, B I – iBGP, B E – eBGP,
R – RIP, I L1 – IS-IS level 1, I L2 – IS-IS level 2,
O3 – OSPFv3, A B – BGP Aggregate, A O – OSPF Summary,
NG – Nexthop Group Static Route, V – VXLAN Control Service,
DH – DHCP client installed default route, M – Martian,
DP – Dynamic Policy Route, L – VRF Leaked

Gateway of last resort:
O E2 0.0.0.0/0 [110/100] via x.x.x.x, Ethernet40

I know the fact that OSPF routes will be installed to the routing table because of lower AD compared to iBGP. That’s fine. But the problem is, from my Arista device it is not sending the 0.0.0.0 prefix to other eBGP peer (no route filtering/map applied for the eBGP neighbor).

Second question, is “#-not installed” is equivalent to “r RIB-failure” in Cisco?

0
Posted by Vikram
Answered on October 17, 2019 10:05 pm

Hi Hairul,

If possible could you please provide the entire running-config and the output of "show ip bgp " as well. I am going to guess that you are running our default single-agent routing protocol mode and in that we do not advertise inactive routes by default. You can override this behavior by using the knob advertise-inactive in bgp. Pls see this TOI article for more information https://eos.arista.com/eos-4-15-0f/bgp-advertise-inactive/. HTH

Thanks for the link, didn't know such command is available. I have implemented workaround based on this post https://eos.arista.com/forum/change-ad-for-specific-prefix-in-bgp-or-ospf/
(Hairul Redzuan Saring at October 22, 2019 3:47 am)
0
Posted by ANURAG MURUGESAN
Answered on October 18, 2019 2:52 am

Hello Hairul,

As the default route currently installed in the routing table of the Switch in question was learnt from OSPF, to advertise this route in BGP, we can either need to redistribute this OSPF route into BGP or configure "default-originate" for the concerned peer and/or peer-groups.

Regards,
Anurag

This is another option, but we put it as a very last option. I've implemented temp fix using this method https://eos.arista.com/forum/change-ad-for-specific-prefix-in-bgp-or-ospf/
(Hairul Redzuan Saring at October 22, 2019 3:49 am)

Post your Answer

You must be logged in to post an answer.