Posted on January 31, 2019 11:46 pm
 |  Asked by Keith
 |  340 views
0
0
Print Friendly, PDF & Email

I am trying to enable simple mutlicast within a VLAN on an Arista 7060CX2 running EOS 4.20.10M. I have tried every combination of configurations and nothing works.

I have a host connected to E1/1 running rhel 7.5 add another with the same OS connected to E1/2. I have tried using both nuttcp and iperf to send the multicast data.

My first configuration was:
ip igmp snooping vlan 10 querier
ip igmp snooping vlan 10 querier address 10.0.0.1
ip igmp snooping querier

But that would not work. The show ip igmp snooping groups command had no output and traffic would not pass from one host to the other.

I then tried enabling ip routing and multicast routing with no effect. I also enabled PIM on the interface. All of which should not be necessary, and none of which worked.

The ONLY way i have been able to send multicast from one host to another was to disable igmp snooping on the switch. Then, iperf would send traffic to the 239.1.2.3 address and the receiver would get it.

HOWEVER, even in this state(igmp snooping turned off), nuttcp still would not work. nuttcp requires the multicast address be 231.x.x.x. These are “reserved” addresses.

I did set up a port mirror(monitor session) and verified the multicast traffic is making it to the switch. It just doesn’t forward the 231.x.x.x addresses AT ALL and only forwards the 239.1.2.3 when snooping is disabled.

Questions:
1. What do i need to do to enable simple intra-vlan multicast with igmp snooping using the switch as a querier?
2. Does the Arista take special action on 231.x.x.x addresses?
3. What other ways are there to debug mutlicast?

1
Posted by Aniket Bhowmick
Answered on February 1, 2019 5:48 am

Hi Keith

IGMP Snooping by default is Enabled but it gets active only when it receives a query in a Vlan or if itself becomes the querier.
When you ran the command: “ip igmp snooping vlan 10 querier”, IGMP snooping got activated for Vlan 10.

At this point if the switch does not receive any IGMP reports from any host in Vlan 10, it will not forward any Multicast packets out of the switch for Vlan 10. This is expected. If the switch receives any report in any Vlan, the “show ip igmp snooping groups” will get populated. Could you please confirm if any report was received on the switch or not? Please run the following command to verify “show ip igmp snooping counters”.

When you disabled IGMP Snooping, Flooding got enabled in which case the Multicast packets must have flooded out of all the ports in that VLAN.

Can you tell us if the receivers and senders were in Same Vlan or not ? If it is not in same Vlan, PIM must be enabled for both the Vlans for multicast routing to work. When the feed would be routed from Vlan-A to Vlan-B (considering receivers are in Vlan-B), feed will be flooded in Vlan-B if IGMP Snooping is not active otherwise Snooping table will be considered to forward the packet. If there is no report received in VLAN-B, the feed will be dropped (if snooping is active). You can check this using the command: show ip igmp snooping.

I am checking regarding the 231.x.x.x address and will get back to you soon. Can you please share the complete IP of 231.x.x.x ?

Thanks !
Aniket

Both hosts are in the same VLAN so PIM is not necessary. If you scroll down you can see my response and a wireshark capture which shows a join being sent but the counter not incrementing on the switch(capture attached as well).

Both hosts are in vlan 10. Config looks like this:ip igmp snooping vlan 10 querier
ip igmp snooping vlan 10 querier address 10.0.0.1
ip igmp snooping querier

interface Vlan10
mtu 8972
ip address 10.0.0.1/16
ip igmp version 2
ip pim sparse-mode

Sparse mode is still turned on in an attempt to get this working but NOTHING WORKS.

Full IP is 231.1.2.3.

(Keith at February 1, 2019 4:08 pm)
0
Posted by Keith
Answered on February 1, 2019 2:41 pm

Here are some attachments to further show the issue. First, is a wireshark capture showing that the host is sending joins and the switch is send queries.

The second picture is the output of the sh ip igmp snooping querier counters command on the switch. It shows that the report count is 0.

I don’t know why this is.

0
Posted by edmund
Answered on February 1, 2019 3:35 pm

Can you share the expanded packet capture? Check the destination MAC address on the IGMP join.

Ed

0
Posted by Keith
Answered on February 1, 2019 4:04 pm

@Ed, attached is the expanded view.

1
Posted by Keith
Answered on February 1, 2019 5:09 pm

Turned the query interval down to 5 seconds. I can see the switch querying and the host responding, but the counter never increments. Is this a bug? How else can I debug?

It’s not a bug. The destination MAC address of the join is unicast so igmp snooping won’t see it. This happens in Linux when you add static route for multicast with a destination IP address. Remove that from your server. If you need a static route point it to the interface instead.

(edmund at February 1, 2019 6:19 pm)

Thanks for the catch Edmund. I revised the routes and it seems to be working now.

(Keith at February 5, 2019 1:42 pm)

Post your Answer

You must be logged in to post an answer.