Posted on February 29, 2020 2:35 pm
 |  Asked by Timothy Patrick
 |  157 views
0
0
Print Friendly, PDF & Email

Hello, I  am fairly new to the Arista product family so i am getting my feet wet with vEos. I  am trying to connect to vEOS switches together via a trunk port and ping a vlan interface between the switches.     SWT1<—–Trunk—-> SWT2

 

Switch1

interface Ethernet3
switchport access vlan 999
switchport trunk allowed vlan 999
switchport mode trunk

interface Vlan999
ip address 1.1.1.1/24

Switch2

interface Ethernet3
switchport access vlan 999
switchport trunk allowed vlan 999

switchport mode trunk

interface Vlan999
ip address 1.1.1.2/24

Switch1(config-if-Et3)#ping 1.1.1.2
PING 1.1.1.2 (1.1.1.2) 72(100) bytes of data.

— 1.1.1.2 ping statistics —
5 packets transmitted, 0 received, 100% packet loss, time 41ms

Switch1 arp entry after ping

1.1.1.2 0:39:34 0050.5635.698d Vlan999, not learned

 

If I  remove the trunk and just have int Ethernet 3 in vlan 999 I  am able to ping across.

 

Promiscuous mode:”, ”MAC address changes:”, and ”Forged transmits:” are all set to accept on my EXi server

0
Posted by ANDREY SEMENOV
Answered on March 2, 2020 1:28 pm

for me it works in vEOS-lab-combined-4.20.15M.vmdk and doesn't in vEOS-lab-4.23.2F.vmdk + Aboot-veos-serial-8.0.0.iso (both in GNS3)

1
Posted by Tamas Plugor
Answered on March 2, 2020 1:46 pm

Hi Timothy,

There's an issue in 4.23.1 and 4.23.2 due to which trunking is broken (tracking under BUG429520). Will be fixed in 4.24, can you please try with 4.22.3M or 4.22.4M, that should work fine!

Thanks,

Tamas

also, just to clarify this only affects vEOS-lab
(Tamas Plugor at March 3, 2020 12:54 pm)
Thank you, I downgraded to the 4.22.3M version and I was able to ping across. I am still seeing weird behavior with bringing up a physical port on a vlan and being able to ping VRF to VRF but if I remove the ethernet port and add the VLAN to the port channel trunk I am no longer able to ping across
(Timothy Patrick at March 4, 2020 4:10 am)

Post your Answer

You must be logged in to post an answer.