Posted on July 26, 2021 2:29 pm
 |  Asked by Guohong Zhou
 |  90 views
0
0
Print Friendly, PDF & Email

Hi experts,

I tried to build a MLAG setup with 3 cEOS instances on MacOS. The MLAG peering can’t be established.
r1#show mlag
MLAG Configuration:
domain-id : 100
local-interface : Vlan4094
peer-address : 10.1.1.2
peer-link : Port-Channel10
peer-config :

MLAG Status:
state : Inactive
negotiation status : Connecting
peer-link status : Lowerlayerdown
local-int status : Lowerlayerdown
system-id : 00:00:00:00:00:00
dual-primary detection : Disabled
dual-primary interface errdisabled : False

MLAG Ports:
Disabled : 1
Configured : 0
Inactive : 0
Active-partial : 0
Active-full : 0

r1#show lldp neighbors
Last table change time : 1:26:26 ago
Number of table inserts : 2
Number of table deletes : 0
Number of table drops : 0
Number of table age-outs : 0

Port Neighbor Device ID Neighbor Port ID TTL
———- ———————— ———————- —
Et1 r2 Ethernet1 120
Et2 r3 Ethernet1 120

I tried to modify the group_fwd_mask as the URL below guided.
https://lists.linuxfoundation.org/pipermail/bridge/2015-January/009292.html
But I found I couldn’t remove restrictions with mask value 65535, although I could allow LLDP with 16384.
Could anyone please help me?

gz@gz-mbp ~ % docker run -it –privileged –pid=host –rm debian nsenter -t 1 -m -u -n -i sh
/ # echo 16384 > /sys/class/net/br-68d5abd09d4b/bridge/group_fwd_mask
/ # echo 65535 > /sys/class/net/br-68d5abd09d4b/bridge/group_fwd_mask
sh: write error: Invalid argument

0
Posted by Daniel Tudares
Answered on July 27, 2021 1:04 am

Hi,

Seems like you are having connectivity issues between the devices. Check your port-channel interface config, are you passing the proper vlan? did you assign the port-channel to the physical interface?. You could post your running config for the interface / port-channel / mlag portions to validate that it's properly configured.

Also, heads up, MLAG can only be achieved between two devices, not 3, so you will need to remove one of your devices from the mlag.

0
Posted by Naveen Chandra
Answered on July 30, 2021 5:18 pm

Hi Guohong,

Thanks for writing to this forum. As my friend Daniel said this looks like a misconfiguration issue. From the below output we can see the peer-link and the local-int both's status is Lowerlayerdown.

peer-link status : Lowerlayerdown
local-int status : Lowerlayerdown

You can share the configuration and the topology diagram with us for further investigation. But I would like to share the below document with you for an introduction and the easy steps to configure the mlag.

https://eos.arista.com/mlag-basic-configuration/

 

Post your Answer

You must be logged in to post an answer.