Posted on December 4, 2019 11:45 pm
 |  Asked by Cindy Moore
 |  69 views
RESOLVED
0
0
Print Friendly, PDF & Email

This is a relatively simple question but I can’t seem to find the answers in the manuals. It’s also entirely possible I am asking the wrong questions, too.

Quick description: I have a main switch where the building uplink comes into.
I have TOR switches on each rack.
There are two vlans on the network, 150 and 200
most of the servers on each rack are using vlan 150.
I have two servers that want to use 200.

So, I need to configure the link between main-switch and rack-switch to admit both 150 and 200.
Then I need to configure two ports on the rack-switch to pass along 200 to the two servers in question.

My understanding is that for multiple vlan, i need to set the port’s switchport to trunk. The problem is that from a prior configuration on the port, I seem to have both switchport access and switchport trunk set (not to mention no switchport as I try to fiddle with the settings). I can’t seem to find anything that clears out a port of all settings so I can start over?

Here are my configurations:

On main-switch:

interface Ethernet49/1
description 40G link to sw-b11
speed forced 40gfull
switchport access vlan 150
switchport trunk native vlan 150
switchport trunk allowed vlan 150,200
switchport mode trunk
!
interface Ethernet49/2
!
interface Ethernet49/3
!
interface Ethernet49/4
!

on the rack-switch:


[...]
interface Ethernet22
switchport access vlan 200
!
interface Ethernet23
switchport access vlan 200
!
[...]
interface Ethernet49/1
description 40G link to main-switch
speed forced 40gfull
switchport access vlan 150
switchport trunk native vlan 150
switchport trunk allowed vlan 150,200
switchport mode trunk
!
[...]

Now on the rack switch, i tried to reconfigure things to get rid of the
switchport access vlan 150 setting on the assumption that I can’t have both access and trunk?
However both are present? Even worse, in trying to turn it off, I get things like


rack-switch(config-if-Et49/1)#no switchport
rack-switch(config-if-Et49/1)#exit
rack-switch(config)#wr mem
Copy completed successfully.
rack-switch(config)#exit
rack-switch#show run int eth 49/1
interface Ethernet49/1
description 40G link to main-switch
speed forced 40gfull
switchport access vlan 150
switchport trunk native vlan 150
switchport trunk allowed vlan 150,200
switchport mode trunk
no switchport
rack-switch#

I mean…whut? Is the latest item the one that is supposed to be in effect? I’m not sure what to make of that.

Also, for testing completeness is there some way for me to check on the main-switch that it is in fact getting traffic on vlan 200?

(Bigger picture, I am migrating a network setup from one switch/network to another; I have this general setup working on layer 2 switches but so far haven’t gotten this to work with these arista switches.)

main-switch is an arista 7150S, rack-switch a 7050S. The rack switch is on the most up to date EOS available for that model, the 7150S is a bit behind mostly b/c it’s too central to take down and upgrade very frequently.

Thanks,
Cindy

0
Answered on December 4, 2019 11:54 pm

Hi Cindy,

Thank you for writing to the forum.
What you see is expected. When we configure "no switchport" on the interface, the command does not remove the switchport configuration but makes the port 'routed'. The interface then is no longer a switchport. Please see the interface status:

(config)#show inter status
Port Name Status Vlan Duplex Speed Type
Et1 connected 666 a-full a-1G 1000BASE-T

(config)#show run int et 1
interface Ethernet1
switchport access vlan 666
(config)#int et 1
(config-if-Et1)#no switchport

(config)#show inter status
Port Name Status Vlan Duplex Speed Type
Et1 connected routed a-full a-1G 1000BASE-T

In order to remove the access port configuration, you will need the "no" before the access port configuration:

no switchport access vlan 150
switchport >>> make the port switchport again

Hope this helps,

Thank you,

Aha! Yes, that helps. Am I correct in thinking that I want only the trunk definitions there and to remove the access def'n? And is there an easy way to see if there's traffic on the vlan? I do note: rack-switch#show vlan 200 VLAN Name Status Ports ----- -------------------------------- --------- ------------------------------- 2764 SECOND active Et22, Et49/1 But I don't know if active just means its set up or if there's actual traffic.
(Cindy Moore at December 5, 2019 12:26 am)

Post your Answer

You must be logged in to post an answer.