Posted on September 11, 2020 4:56 pm
 |  Asked by mah m
 |  39 views
0
0
Print Friendly, PDF & Email

Hello,

Always the change controls are failing after message “Waiting up to 900 seconds for Terminattr update from: “

But the actual config is updated on the switch and it is streaming properly. Any specific reason for this and how to troubleshoot this?

0
Posted by Tamas Plugor
Answered on September 11, 2020 5:05 pm

Hey!

That can be due to any of the following reasons:

  • NTP is not configured on the device (this is mandatory so that streaming latency is calculated correctly)
  • you are running older TerminAttr version than 1.6.1 which does not have running-config activity key (can be checked on the switch side with curl localhost:6060/rest/Config/running | grep activity
  • you are running old EOS version (pre 4.20) and protocol unix-socket is not configured under management api http-commands which would mean the running-config is not streamed to CVP

TerminAttr has to stream the activity key to the backend after configuration push for a final verification, if that is not happening, the task will not finish successfully, even though the config gets pushed to the device.

HTH,

Tamas

0
Posted by mah m
Answered on September 12, 2020 2:37 am

Thanks for the reply, Tamas. We are running 4.21 and Terminattr version is 1.6.1.

We are not using NTP here, but I can see the timing between CVP and swithes is having <30s difference.

I will check by setting up NTP.

Post your Answer

You must be logged in to post an answer.