Posted on July 20, 2018 3:25 pm
 |  Asked by Denislav Denchev
 |  1092 views
RESOLVED
0
0
Print Friendly, PDF & Email

Hello,

I am new to Arista technology and I am trying to set up CVX with 3 Arista vEOS VMs.
I installed another instance of the same vEOS (4.18.1F in my case) on the same ESXi host.
I configured the CVX server side as written in the CV config manual.
I configured the client side as written in the CV config manual but it stays in connecting state.
My questions are:
– which CVX IP address must I use as a #server host argument on the client side (in my case I have only ma 1 configured on the CVX server VM)?
– do I need to configure a loopback interface on the CVX server VM also?
– if not how will the client communicate with the CVX server if the lo 5 (client side) and the ma 1 (server side) are on different subnets? routing?

Regards,
Denislav

0
Answered on July 20, 2018 3:30 pm

Hi Denislav,

To your questions:
1. Since you have only ma1 on CVX, you can point your vEOS client switches to talk to CVX’s ma1 IP.
2. No loopback is required on CVX.
3. All you need is IP reachability from the client to server. If they are on different subnets, you’ll need some form of routing as you mentioned.

For production deployments, we recommend in-band design. You can find deployment recommendations here.

Cheers
Naveen

Hi Naveen,

May be it is something very simple but I still can’t make it work.
Here is the CVX conf:
! Command: show running-config
! device: CVX (vEOS, EOS-4.18.1F)
!
! boot system flash:/vEOS-lab.swi
!
cvx
no shutdown
heartbeat-interval 30
heartbeat-timeout 90
!
transceiver qsfp default-mode 4x10G
!
hostname CVX
ip host arista-01 10.10.0.127
ip host arista-02 10.10.0.128
ip host arista-03 10.10.0.129
!
spanning-tree mode mstp
!
no aaa root
!
username admin role network-admin secret sha512 $6$/G8rpFzaQ03ND7KL$5v6bHXKxaeSag6dcvmujRmfpR/scH2WdpFgP0ncPw4OOSBtmeVXX/TgARu74Mh5/O9PysNjq.uC7SEI0Bos1Y/
!
clock timezone Europe/Sofia
!
interface Ethernet1
!
interface Ethernet2
!
interface Management1
ip address 10.10.0.130/24
!
ip route 0.0.0.0/0 10.10.0.1
!
no ip routing
!
end

and here is 1 client conf:

! Command: show running-config
! device: arista-01 (vEOS, EOS-4.18.1F)
!
! boot system flash:/vEOS-lab.swi
!
transceiver qsfp default-mode 4x10G
!
hostname arista-01
ip name-server vrf default 16.110.135.51
ip host arista-02 10.10.0.128
ip host arista-03 10.10.0.129
ip host cvx 10.10.0.130
!
spanning-tree mode mstp
spanning-tree mst 0 priority 8192
!
no aaa root
!
username admin role network-admin secret sha512 $6$yST8aM0/WaSTxA7A$h6gBGtO6R1aKFiWYqR9KFtyyhVf2cDLGF.cIl/QdMSCD9NGdalYYUEQl5u15rKgTs6d/spInJ6u5fQx1i0KuO.
!
clock timezone Europe/Sofia
!
interface Ethernet1
!
interface Ethernet2
!
interface Ethernet3
!
interface Loopback5
ip address 10.10.100.2/24
!
interface Management1
ip address 10.10.0.127/24
!
ip route 0.0.0.0/0 10.10.0.1
!
ip routing
!
management cvx
no shutdown
server host 10.10.0.130
source-interface Loopback5
heartbeat-interval 30
heartbeat-timeout 90
!
end

and here is what I get as a client status:

arista-01#sh management cvx
CVX Client
Status: Enabled
Source interface: Loopback5 (10.10.100.2)
VRF: default
Heartbeat interval: 30.0
Heartbeat timeout: 90.0
Controller cluster name: default
Controller status for 10.10.0.130
Connection status: connecting
Out-of-band connection: Not secured
In-band connection: Not secured (SSL not supported)
Negotiated version: Not negotiated
Controller UUID:
Last heartbeat sent: never
Last heartbeat received: never

Can You please help?

Regards,
Denislav

(Denislav Denchev at July 25, 2018 11:58 am)
0
Posted by Denislav Denchev
Answered on July 25, 2018 11:52 am

Hi Naveen,

Thanks for the answer!

May-be it is something very simple but I still cannot make it run.
Here is the cvx VM configuration:
! Command: show running-config
! device: CVX (vEOS, EOS-4.18.1F)
!
! boot system flash:/vEOS-lab.swi
!
cvx
no shutdown
heartbeat-interval 30
heartbeat-timeout 90
!
transceiver qsfp default-mode 4x10G
!
hostname CVX
ip host arista-01 10.10.0.127
ip host arista-02 10.10.0.128
ip host arista-03 10.10.0.129
!
spanning-tree mode mstp
!
no aaa root
!
username admin role network-admin secret sha512 $6$/G8rpFzaQ03ND7KL$5v6bHXKxaeSag6dcvmujRmfpR/scH2WdpFgP0ncPw4OOSBtmeVXX/TgARu74Mh5/O9PysNjq.uC7SEI0Bos1Y/
!
clock timezone Europe/Sofia
!
interface Ethernet1
!
interface Ethernet2
!
interface Management1
ip address 10.10.0.130/24
!
ip route 0.0.0.0/0 10.10.0.1
!
no ip routing
!
end

and here is a client arista configuration:

! Command: show running-config
! device: arista-01 (vEOS, EOS-4.18.1F)
!
! boot system flash:/vEOS-lab.swi
!
transceiver qsfp default-mode 4x10G
!
hostname arista-01
ip name-server vrf default 16.110.135.51
ip host arista-02 10.10.0.128
ip host arista-03 10.10.0.129
ip host cvx 10.10.0.130
!
spanning-tree mode mstp
spanning-tree mst 0 priority 8192
!
no aaa root
!
username admin role network-admin secret sha512 $6$yST8aM0/WaSTxA7A$h6gBGtO6R1aKFiWYqR9KFtyyhVf2cDLGF.cIl/QdMSCD9NGdalYYUEQl5u15rKgTs6d/spInJ6u5fQx1i0KuO.
!
clock timezone Europe/Sofia
!
interface Ethernet1
!
interface Ethernet2
!
interface Ethernet3
!
interface Loopback5
ip address 10.10.100.2/24
!
interface Management1
ip address 10.10.0.127/24
!
ip route 0.0.0.0/0 10.10.0.1
!
ip routing
!
management cvx
no shutdown
server host 10.10.0.130
source-interface Loopback5
heartbeat-interval 30
heartbeat-timeout 90
!
end

and here is what I observe as CVX status at the client side:

arista-01#sh management cvx
CVX Client
Status: Enabled
Source interface: Loopback5 (10.10.100.2)
VRF: default
Heartbeat interval: 30.0
Heartbeat timeout: 90.0
Controller cluster name: default
Controller status for 10.10.0.130
Connection status: connecting
Out-of-band connection: Not secured
In-band connection: Not secured (SSL not supported)
Negotiated version: Not negotiated
Controller UUID:
Last heartbeat sent: never
Last heartbeat received: never

Can You please help?

Regards,
Denislav

0
Answered on July 25, 2018 3:35 pm

Hi Denislav,

I see both CVX and the client are in the same management subnet 10.10.0.0/24. Is there a specific reason why you are sourcing the CVX-bound traffic from Loopback5 on the client? This is generally fine but you’ll need to make sure routing is setup correctly. Are you able to ping client’s Loopback5 IP from the CVX instance?

It appears you are using the same vEOS-lab.swi image for CVX instance as well. vEOS-lab is for vEOS only; you’ll need to use EOS-4.x.y.vmdk for the CVX instance.

Cheers
Naveen

Hi Naveen,

I configured the source interface to be Loopback5 because that is what is written in the CV Config Guide… With the Ma 1 being the source – it works.

I tried to replace the EOS image but I have here the problem that I cannot boot this image – tried EOS-4.18.8M.vmdk and EOS-4.18.8M.vmdk – different messages but the VM cannot boot. Aboot seems to be OK because when I remove the vmdk from the VM config (so the VM has no HDD) – I can interact with Aboot.
What are the correct VM settings? – ESXi 5.5 format and Other Linux (62 bit)?
For the vEOS VMs I use 5.0 format and Other Linux 2.6 (32bit) and they work.

I am using ESXi 6.5 – any specialties there? (I converted the .vmdk to eagerzeroedthick – this did not help)

Lastly (for training purposes) is it mandatory to use EOS image instead of the vEOS?

Regards,
Denislav

(Denislav Denchev at July 26, 2018 1:11 pm)
0
Answered on July 26, 2018 3:52 pm

Hi Denislav,

You can find the detailed steps here.

Some key things to note:
1. Re-formatting the .vmdk to thick is no longer necessary in ESXi 6.5 as it was with ESXi 6.0
2. Select ‘ESXi 5.5 and later’ for VM Compatibility
3. OS type is ‘Other Linux (64 bit)’
4. Use all defaults for Network Adapter type (vmxnet3)

For lab use, you can run CVX on vEOS-lab image but not recommended for production deployments. If you need further assistance with setting up the VM, you might want to open a case with Arista TAC.

Cheers
Naveen

Post your Answer

You must be logged in to post an answer.