Posted on August 4, 2015 1:19 pm
 |  Asked by Andre Timmermann
 |  1002 views
RESOLVED
0
0
Print Friendly, PDF & Email

Hi,

we have two datacenters connected with a 1 Gbit fiber connection. I would like to configure a backup connection via the 1 Gbit uplinks. (A second fiber is NOT feasible as one of the DCs do not offer a second physical entry into the building. That means if one fiber is killed by  a backhoe, both are killed…) As far as I understand this can be achieved with Vxlan. Unfortunately I simply do not understand the guidelines in http://www.arista.com/assets/data/pdf/Whitepapers/Arista_Design_Guide_DCI_with_VXLAN.pdf

I set up a demo env vie vEOS with two “datacenters” with two arista switches each. They are connected via a virtual linux box playing router.

DC1 / veos1:

interface Ethernet1
description routing / vboxnet3
switchport access vlan 3
!
interface Vlan3
ip address 10.199.0.10/24
ip route 0.0.0.0/0 172.16.0.1

DC2 / veos3:

interface Ethernet1
description routing / vboxnet4
switchport access vlan 4
!
interface Vlan4
ip address 172.16.0.10/24
ip route 0.0.0.0/0 172.16.0.1

Router:

eth1: 10.199.0.1/24
eth2: 172.16.0.1/24

How do I set up the tunnel to get a layer 2 connection between these virtual datacenters? Can someone point me into the right direction please?

In the real DCs we have Arista DCS-7050T-52-R with software image version 4.12.3.1
As far as I understand I have to upgrade to a 4.15.x to use the tunneled layer 2?

Best regards,
Andre

0
Posted by ma
Answered on August 4, 2015 7:38 pm

Hi Andre,

Thank you for posting your questions.

The Arista DCS-7050T-52 switches are using a Trident+ ASICS which unfortunately has no support for VXLAN bridging. Support for VXLAN bridging in hardware was introduced in the TridentII ASIC. We are using these TridentII ASICs in our 7050X series of switches. i.e. DCS-7050TX-48-R, which is a 48x 1/10G copper switch with 4x QSFP+(40G) uplinks.
You should be able to test the concept of VXLAN bridging in your vEOS environment.

Couple of questions to better understand your idea:
1) Can you confirm that the the current 1Gbit fiber connection between the two DC is a L2 connection
2) What is this 1Gbit uplink you are referring to, is this a L3 Internet connection

Let me try to explain below simple configuration you could use to setup VXLAN between two DCs using vEOS:
– Eth1 is connected to another vEOS switch either via a L3 P2P or a L3 routed network.
– Eth2 is connected to a server via a 802.1q trunk, allowing VLAN 100 and 200
– Lo1 is used for VTEP (Virtual Tunnel End Point) reachability. The VXLAN packets will use this IP as either the SRC or DST as the outer IP. This address is preferable advertised via a routing protocol to the remote DC (VTEP)
– VXLAN1 interface has the following config:
– vxlan vlan 100 vni 100000 – means encapsulate all packets coming in with VLAN tag 100 in this case from Eth2 into a VXLAN packet with DST outer IP 1.1.1.1 and use VNI (Virtual Network Identifier) 100000.
– vxlan flood vtep 1.1.1.1 – will send all incoming BUM (Broadcast, Unknown unicast and Multicast) traffic on VLAN 100 and 200 to the remote DC (VTEP 1.1.1.1)

interface Ethernet1
no switchport
ip address 10.1.2.1/31
!
interface Ethernet2
description Connection to production switch
switchport trunk allowed vlan 100,200
switchport mode trunk
!
interface Loopback1
description VXLAN VTEP IP address
ip address 2.2.2.2/32
!
interface Vxlan1
vxlan source-interface Loopback1
vxlan udp-port 4789
vxlan vlan 100 vni 100000
vxlan vlan 200 vni 200000
vxlan flood vtep 1.1.1.1

Best regards,
-Michael

Post your Answer

You must be logged in to post an answer.