Posted on April 1, 2020 11:59 am
 |  Asked by Mencken Davidson
 |  147 views
RESOLVED
0
0
Print Friendly, PDF & Email

I notice that the CLI will accept the configuration in the most recent release, but the subinterfaces all show up with all-zero MAC addresses and the routes never make it into the route-table.

Any assistance greatly appreciated.

0
Posted by Sahil
Answered on April 7, 2020 4:45 am

Hi Mencken,

Thank you for posting your query here.

Well at this point of moment cEOS does not support subinterfaces. Our teams are working on it to have this feature available soon. The workaround is to use port-channel interfaces instead of subinterfaces.

Let us know if you have any other questions.

Cheers,

Sahil Sharma

0
Posted by Sreelekha
Answered on April 9, 2020 6:50 am

Hey Mencken,

Thanks for writing to the forum.

There is a known bug in all the existing releases till 4.23.2F due to which sub-interfaces on cEOS do not work. That is because of the etba agent not able to recognise the parent ethernet interfaces due to a different naming format picked by the docker. They might work in few scenarios (based on how the eth interfaces are named) but we have seen few agent crashes continuously in those setups.

One work around is to use port-channel sub-interfaces. But this will be useful only if you have limited sub-interfaces.

The fix for the above bug is yet to be shipped in future releases.

Hope this helps. Cheers!

Sreelekha

 

 

 

 

0
Posted by Mencken Davidson
Answered on April 23, 2020 8:16 pm

Many thanks!

Post your Answer

You must be logged in to post an answer.