Posted on November 23, 2015 2:26 pm
 |  Asked by Kursad Aydogan
 |  2102 views
RESOLVED
0
0
Print Friendly, PDF & Email

Hello,

I implemented Arista as tapagg but there are too much framing overhead on tap interfaces. I changed mtu size as 9214 but the problem is going on still. How can i fix that this problem?  You can find interface’s output at the below.

Thanks.

CamlicaSpan#sh int eth1

[?1h=

Ethernet1 is up, line protocol is up (connected)

Hardware is Ethernet, address is 444c.a820.b706 (bia 444c.a820.b706)

Description: SW.6500.Port.2.3.47

Ethernet MTU 10218 bytes , BW 1000000 kbit

Full-duplex, 1Gb/s, auto negotiation: on, uni-link: disabled

Up 3 hours, 21 minutes, 54 seconds

Loopback Mode : None

0 link status changes since last clear

Last clearing of “show interface” counters 0:08:03 ago

5 minutes input rate 354 Mbps (36.3% with framing overhead), 52452 packets/sec

5 minutes output rate 0 bps (0.0% with framing overhead), 0 packets/sec

31467569 packets input, 26736313522 bytes

Received 6387 broadcasts, 44658 multicast

0 runts, 0 giants

0 input errors, 0 CRC, 0 alignment, 0 symbol, 0 input discards

0 PAUSE input

0 packets output, 0 bytes

Sent 0 broadcasts, 0 multicast

0 output errors, 0 collisions

0 late collision, 0 deferred, 0 output discards

0 PAUSE output

[K[?1l>CamlicaSpan#sh int eth1[K2

[?1h=

Ethernet2 is up, line protocol is up (connected)

Hardware is Ethernet, address is 444c.a820.b707 (bia 444c.a820.b707)

Description: SW.6500.Port.1.3.48

Ethernet MTU 10218 bytes , BW 1000000 kbit

Full-duplex, 1Gb/s, auto negotiation: on, uni-link: disabled

Up 3 hours, 20 minutes, 37 seconds

Loopback Mode : None

0 link status changes since last clear

Last clearing of “show interface” counters 0:08:05 ago

5 minutes input rate 273 Mbps (28.0% with framing overhead), 43917 packets/sec

5 minutes output rate 0 bps (0.0% with framing overhead), 0 packets/sec

26931776 packets input, 21057399466 bytes

Received 9508 broadcasts, 36647 multicast

0 runts, 0 giants

0 input errors, 0 CRC, 0 alignment, 0 symbol, 182653 input discards

0 PAUSE input

0 packets output, 0 bytes

Sent 0 broadcasts, 0 multicast

0 output errors, 0 collisions

0 late collision, 0 deferred, 0 output discards

0 PAUSE output

0
Posted by Juuso Lehtinen
Answered on November 23, 2015 6:20 pm

Hi Kursad,

The percentage numbers on the following line doesn’t mean that you have 36.3% of framing overhead:

5 minutes input rate 354 Mbps (36.3% with framing overhead), 52452 packets/sec
5 minutes output rate 0 bps (0.0% with framing overhead), 0 packets/sec

The percentage number here refers to the interface utilization rate. This percentage number is taking the framing overhead into account, whereas the plain input rate Mbps number doesn’t include the framing overhead.

In your case, this interface is running in 1Gbps speed and it is receiving 354 Mbps of traffic. As the average frame size is fairly large (354 Mbps / 52452 packets/sec => 843 bytess/frame), the framing overhead in this case is pretty minimal: 36.3% – 354Mbps/1Gbps => 0.9%.

In general, there is no way you can control the framing overhead on the receiving side of an Ethernet link. The only way to reduce framing overhead is to make sure that the application on the sending side of the Ethernet link is sending large frames.

-Juuso

 

0
Posted by John Gill
Answered on November 25, 2015 10:29 pm

Can you clarify the problem you are observing?

Post your Answer

You must be logged in to post an answer.