Posted on July 28, 2017 4:58 pm
 |  Asked by Sorin Renghea
 |  4370 views
RESOLVED
0
1
Print Friendly, PDF & Email

Hi,

I have an Arista 7160 running 4.18.0f, with default configuration and I send multicast traffic to one of the interfaces. I have noticed that the traffic is flooded to all interfaces from the respective vlan.

How can I disable this behaviour? I want to stop the multicast traffic when no clients are installed.

Something similar to “switchport block multicast enabled” from Cisco. , or “no flood” on Lenovo switches.

Thanks,

Cristi

 

 

Marked as spam
0
Posted by Upasana Dangi
Answered on July 28, 2017 6:12 pm

Hi Cristi,

One mechanism to disable flooding would be to have IGMP snooping enabled for the vlans where flooding is undesired. 

On Arista devices, while snooping is enabled by default, we would need to configure a snooping querier for it to be made effective.

Example:

Without Querier enabled:

switch(config)#show ip igmp snooping vlan 10

Vlan 10 :

———-

IGMP snooping                  : Enabled

IGMP snooping pruning active   : False

Flooding traffic to VLAN       : True

 

With Querier enabled:

The switch would require a querier to be present in the L2 environment. If no querier is presently configured, we can also configure the switch itself as the querier for the specific vlans:

Example:

switch(config)#ip igmp snooping vlan 10 querier

switch(config)#ip igmp snooping vlan 10 querier address 1.1.1.1

switch#sh ip igmp snooping vlan 10

Vlan 10 :

———-

IGMP snooping                  : Enabled

IGMP snooping pruning active   : True

Flooding traffic to VLAN       : False

At this point the multicast traffic should only be sent towards the receivers that have requested the same via an IGMP join.

 

We can also alternatively configure a global querier if all vlans have the same requirement:

Example:

switch(config)#ip igmp snooping querier

switch(config)#ip igmp snooping querier address 1.1.1.1

 

0
Posted by Roberto Salazar
Answered on July 28, 2017 7:11 pm

Snooping is enabled for all vlans by default on Arista switches but will not be effective (IGMP snooping pruning will not be active in Arista) till there is a valid querier present in the L2 domain

On Arista devices a querier can be configured via:

On L2 switch:

If we cannot enable PIM, we can configure IGMP querier via:

ip igmp snooping vlan X querier

ip igmp snooping vlan X querier address x.x.x.x 

or having a PIM enabled SVI/Interface:

ip pim sparse mode → In addition to PIM hello switch will generate a IGMP query 

 

Hence by activating the igmp snooping via having a querier or having a pim enabled SVI for that vlan you can stop the flooding.

 

0
Posted by Harshita Rastogi
Answered on July 28, 2017 8:01 pm

Hello Cristi,

By default, on Arista switches IGMP snooping is enabled but not active.You can verify this by running the following command.You can see the flooding traffic to vlan is set to true.

#sh ip igmp snooping vlan 1

   Global IGMP Snooping configuration:

——————————————-

IGMP snooping                  : Enabled

IGMPv2 immediate leave         : Enabled

Robustness variable            : 2

Report flooding                : Disabled

 

Vlan 1 :

———-

IGMP snooping                  : Enabled

IGMPv2 immediate leave         : Default

Multicast router learning mode : pim-dvmrp

IGMP max group limit           : No limit set

Recent attempt to exceed limit : No

Report flooding                : Disabled

IGMP snooping pruning active   : False

Flooding traffic to VLAN       : True

 

To stop multicast traffic from flooding you can configure a querier for that vlan.Configuring a querier will activate snooping and thus traffic will be sent to only those ports where it received a IGMP report.Since you do not have any receivers it will not send multicast traffic out of any ports.

Here is the command to configure the querier.Querier ip address can be any dummy ip.

(config)#ip igmp snooping vlan 1 querier

(config)#ip igmp snooping vlan 1 querier address 1.1.1.3

 

0
Posted by Sorin Renghea
Answered on July 31, 2017 7:09 am

Thank you for the answers, the IGMP querier configuration resolved the problem,

Regards,

Cristi

 

Post your Answer

You must be logged in to post an answer.