0
0
Print Friendly, PDF & Email

I have an device: arista (DCS-7060CX-32S, EOS-4.15.1FX-7060X.1) which is configured with 25Gig Speed and connected to servers. I need to set VLAN ID TAGGED for a port without using port mode as trunk or access.

The device has not support to TAP option can anyone suggest me in tagging VLAN ID for an port without using TRUNK or ACCESS mode.

Attaching the commands supported by device: arista (DCS-7060CX-32S, EOS-4.15.1FX-7060X.1)

Attachments:
Marked as spam
0
Posted by Richard
Answered on January 20, 2016 5:24 pm

You can configure a routed port to provide vlan tagging with the following command:

interface Ethernet
encapsulation dot1q vlan

If you would like to support multiple vlan tags on a single physical routed interface you can configure the following:

interface Ethernet.
encapsulation dot1q vlan
ip address

Is this what you are searching for?

0
Answered on January 21, 2016 7:55 am

Thanks for reply Richard.

I had HP 5900 Switch which had below parameters for ports connecting to server

interface Ten-GigabitEthernet1/0/6
port link-mode bridge
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 210 to 211 tagged
port hybrid vlan 200 untagged
port hybrid pvid vlan 200

I was looking for similar kind of config in Arista for tagging multiple VLAN ID’s to a single port from Switch.

Currently I have achieved this multiple VLAN tagged using trunk mode. My Question was is there some  option to achieve this without using trunk mode.
arista(config-if-Et1/1)#show interfaces vlans
Port       Untagged Tagged
Et1/1      200      1,100,201-202,209-211,250

switchport command supports only trunk mode for configuring multiple VLAN for a port.

arista(config-if-Et1/1)#switchport ?
access         Set access mode characteristics of the interface
backup         Specify a backup interface
mac            Configure MAC learning on this interface
mode           Set trunking mode of the interface
port-security  Configure MAC-address-based port security
private-vlan   Set the private VLAN configuration
trunk          Set trunking characteristics of the interface
vlan           VLAN mapping commands
<cr>

arista(config)#int ethernet 1/1
arista(config-if-Et1/1)#show active
interface Ethernet1/1
speed forced 25gfull
switchport trunk native vlan 200
switchport mode trunk
arista(config-if-Et1/1)#show interfaces ethernet 1/1 status
Port       Name              Status       Vlan        Duplex  Speed Type
Et1/1                        connected    trunk         full    25G 100GBASE-CR4

0
Posted by Jose Cordones
Answered on February 24, 2016 9:02 pm

I think that there is some confusion about terminology.

What are you trying to avoid, beside whether something is called a trunk or not?

For the HP switch, you do have a trunk there, and you are specifying which vlans are tagged, and which one is the untagged vlan. All of this translates straight through to Arista or Cisco. And it appears that you want one of the Vlans to be a PVLAN. So far, so good?

It’s been a while since I played with PVLANs (Cisco), and even much longer since I played with an HP switch.

I will leave to someone else to answer whether you can mix PVLANs and trunking in the same port, although as far as having a PVLAN be part of a trunk, that should be doable.

 

Hope that helps.

0
Posted by Spencer Ryan
Answered on May 12, 2016 3:00 am

This will mimic the config of the HP port

 

interface Ethernet1

switchport trunk native vlan 200
switchport trunk allowed vlan 200,210-211
switchport mode trunk

As others have said the difference between what vendors call a ”trunk” port changes. Arista follows what Cisco does.

 

PVID is what they call the native or untagged VLAN, (switchport trunk native vlan XXX)

switchport trunk allowed vlan tells the switch which VLANs to allow on the trunk, you must include the native VLAN as well (I did in the example)

and then switchport mode trunk to put the port in .1q mode.

Post your Answer

You must be logged in to post an answer.