Posted on January 22, 2014 11:22 pm
 |  Asked by Unknown
 |  16159 views
RESOLVED
0
0
Print Friendly, PDF & Email

If i configure an interface Ethernet 24 as follows:

interface Ethernet24
   no switchport
   ip address 192.168.81.86/30
   ip ospf cost 1
   ip ospf authentication message-digest
   ip ospf authentication-key Test01!

And the other side, a Cisco 4900 series switch, as follows:

interface TenGigabitEthernet1/52
   no switchport
   ip address 192.168.81.85 255.255.255.252
   ip ospf authentication message-digest
   ip ospf authentication-key Test01!
   ip ospf cost 1

I get the following OSPF errors on Arista side:

Apr 13 12:33:39 Switch1 Rib: OSPF: invalid Hello (1) packet 192.168.81.85 -> 224.0.0.5: Invalid authentication key (24)
Apr 13 12:34:44  Rib: last message repeated 7 times
Apr 13 12:35:52  Rib: last message repeated 7 times
Apr 13 12:36:58  Rib: last message repeated 7 times
Apr 13 12:38:04  Rib: last message repeated 6 times
Apr 13 12:39:04  Rib: last message repeated 7 times

Is there any way I could get OSPF on Arista to work with Cisco without authentication?

Marked as spam
0
Posted by Andrei Dvornic
Answered on January 22, 2014 11:25 pm
Your issue here is that you have configured the interfaces to use message digest authentication and then configured a standard OSPF authentication key. These are 2 separate functions. In order to use the simple password key you have configured, you’d need to remove the message-digest keyword in your ip ospf authentication statement. Something like this will work in the interface context of both the Cisco and Arista:
ip ospf authentication
ip ospf authentication-key Test01!
If you would like to use the message digest authentication (it does offer message encryption), then you would need to configure that key via ip ospf message-digest-key, like this:
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 Test01!

Post your Answer

You must be logged in to post an answer.