Posted on March 13, 2017 6:49 pm
 |  Asked by Arthur Liew
 |  794 views
RESOLVED
0
0
Print Friendly, PDF & Email

Hi Guys,

I’ve been trying hard to get Arista ML2 driver working on my centos packstack environment

     Steps I have taken

  1. packstack for openstack install
  2. yum install python-jsonrpclib
  3. yum install python-networking-arista
  4. edit neutron.conf, ml2_conf_arista.ini, ml2_conf.ini etc

I’ve not been able to get the driver the run. During service neutron-server restart, the follow error popped up

2017-03-12 05:21:17.562 4619 ERROR stevedore.extension [-] Could not load ‘arista’: No module named i18n
2017-03-12 05:21:17.563 4619 WARNING stevedore.named [-] Could not load arista

After some search, I noticed Arista package is installed in /usr/lib/python2.7/site-packages/networking_arista

This is in contrast to all other ML2 driver (openvswitch, gre etc) that is installed in /usr/lib/python2.7/site-packages/neutron/plugins/ml2/drivers

Could this be the problem? What would be the formal Arista ML2 driver installation steps? yum install python-networking-arista doesn’t seem to install to the right directory

Any suggestions?

Rgds

Arthur 

 

0
Answered on March 23, 2017 11:51 am

Hi Arthur,

As a first step make sure that you installed the networking-arista is the latest version for the OpenStack distribution you are running:

Newton sudo pip install “networking-arista>=2016.2,<2017.1”
Mitaka sudo pip install “networking-arista>=2016.1,<2016.2”
Liberty sudo pip install “networking-arista>=2015.2,<2016.1”
Kilo sudo pip install “networking-arista>=2015.1.5,<2015.2”

The mandatory ml2_config_arista.ini is next:

Edit /etc/neutron/plugins/ml2/ml2_conf_arista.ini as follows:

 

[ml2_arista]

eapi_host=set a comma separated list of IP addresses for each CVX instance

eapi_username=<user name>

eapi_password=<password for above user>

Note: If CVX has been deployed in a highly available (HA) cluster, specify each instance IP separated by a comma.

If the ml2_conf_arista.ini file is not present in the /etc/neutron/plugins/ml2 directory, copy it from etc/ml2_config_arista.ini under the networking-arista installation directory or from https://github.com/openstack/networking-arista/blob/master/etc/ml2_conf_arista.ini

Final step is to please restart the OpenStack Neutron server on all nodes it is running on after completing the configuration steps above and passing the ml2_conf_arista.ini file as a –config-file parameter to OpenStack Neutron.

Hope this helps, but feel free to reach out to support@arista.com if you are still having problems

0
Posted by Arthur Liew
Answered on March 28, 2017 7:40 am

Hi Colin,

Thanks very much ! Manage to get it working with help from Arista SE. Cheers !

Rgds

Arthur

Post your Answer

You must be logged in to post an answer.