Posted on May 27, 2020 12:24 am
 |  Asked by Pok Fung Chan
 |  136 views
Tags:
0
0
Print Friendly, PDF & Email

I am new to Arista switch and EOS. I followed the guide in this website: https://eos.arista.com/arista-eapi-101/

 

However, when I tried to enter “show management api http-commands” into the switch,  I only got

switch#show management api http-commands
Enabled: Yes
HTTPS server: running, set to use port 443
HTTP server: running, set to use port 8080
Local HTTP server: shutdown, no authentication, set to use port 8080
Unix Socket server: shutdown, no authentication
VRFs: default
Hits: 0
Last hit: never
Bytes in: 0
Bytes out: 0
Requests: 0
Commands: 0
Duration: 0.000 seconds
SSL Profile: none
FIPS Mode: No
QoS DSCP: 0
Log Level: none
CSP Frame Ancestor: None
TLS Protocols: 1.0 1.1 1.2

There is no URLs and ip address. I am not able to reach the eAPI from the web browser

0
Posted by Tamas Plugor
Answered on May 27, 2020 12:28 am

Do you have any interfaces/SVIs that have an IP address set and can you ping/ssh to that device? Without an IP on the device you won't be able to access the switch using eAPI over http/https, only using unix-socket locally on the switch

Post your Answer

You must be logged in to post an answer.