Posted on April 24, 2019 5:31 pm
 |  Asked by martin Bergerot
 |  120 views
Tags:
RESOLVED
0
0
Print Friendly, PDF & Email

Hi all,

I am trying to establish iBGP between 2 Arista devices in a VRF, and got this error:
Peering failure hint: Open Message Error/bad BGP ID
Do you what what does it mean?

The current status is:

DEFRA2-NDSW99#sh ip bgp nei vrf PSP
BGP neighbor is 10.208.1.140, remote AS 65508, internal link
BGP version 4, remote router ID 0.0.0.0, VRF PSP
Failed connection attempts is 321
Idle-restart timer is inactive
BGP state is Active
Peering failure hint: Open Message Error/bad BGP ID
Last sent notification:Open Message Error/bad BGP ID, Last time 00:01:48, First time 35d13h, Repeats 41026
Last rcvd notification:Open Message Error/bad BGP ID, Last time 21:10:37, First time 34d14h, Repeats 560
Local AS is 65508, local router ID 10.208.114.33

DEFRA6-NDSW99#sho ip bgp nei vr PSP
BGP neighbor is 10.208.1.141, remote AS 65508, internal link
BGP version 4, remote router ID 0.0.0.0, VRF PSP
Failed connection attempts is 321
Idle-restart timer is inactive
BGP state is Active
Peering failure hint: Open Message Error/bad BGP ID
Last sent notification:Open Message Error/bad BGP ID, Last time 00:01:48, First time 35d13h, Repeats 41026
Last rcvd notification:Open Message Error/bad BGP ID, Last time 21:10:37, First time 34d14h, Repeats 560
Local AS is 65508, local router ID 10.208.114.33

Config is mirrored:

interface vlan725
vrf forwarding PSP
ip address 10.208.1.141/28
ip virtual-router address 10.208.1.142
router bgp 65508
vrf PSP
local-as 65508
router-id 10.208.114.33
timers bgp 10 30
no bgp default ipv4-unicast
neighbor IBGP peer-group
neighbor IBGP remote-as 65508
neighbor IBGP next-hop-self
neighbor IBGP fall-over bfd
neighbor IBGP maximum-routes 10
neighbor 10.208.1.140 peer-group IBGP
redistribute static route-map RM-PSP-STATIC-TO-BGP
address-family ipv4
neighbor 10.208.114.34 activate
neighbor 10.208.1.140 activate

Thanks!

0
Posted by Mark Rayson
Answered on April 24, 2019 5:37 pm

Looks like you’re using the same BGP Router ID on both routers hence the bad BGP ID error. Change one and the peering should come up.

0
Answered on April 24, 2019 5:42 pm

It looks like the local router ID for both devices is 10.208.114.33. Could you please double check the BGP router ID configuration on both switches?

0
Posted by Christie Joseph
Answered on April 24, 2019 10:48 pm

Hello Martin,

Looks like both devices are configured with the same router-ID.
Can you confirm the configs on both sides?
DEFRA2-NDSW99#Local AS is 65508, local router ID 10.208.114.33
DEFRA6-NDSW99#Local AS is 65508, local router ID 10.208.114.33

0
Posted by Roberto Salazar
Answered on April 25, 2019 1:03 am

This output on both DEFRA2-NDSW99 and DEFRA6-NDSW99:
Local AS is 65508, local router ID 10.208.114.33

The output above tells me that you might have accidentally configured both router with the same router id:10.208.114.33. The router-id have to be unique, try correcting the duplicate router-id and see if that corrects the issue.

0
Posted by Rishabh N Panickar
Answered on April 25, 2019 2:46 am

Hello Martin,

This message essentially means that both the peering routers have the same ‘router-id’ assigned to them.

For iBGP peering, if both the routers have the same router-ids then the connection will be terminated with BAD BGP ID notification. Could you assign unique router-ids and check if the peering comes UP?

For ex.
(config)#router bgp
switch(config-router-bgp)#router-id A.B.C.D

0
Posted by martin Bergerot
Answered on April 25, 2019 5:28 am

Hi Roberto,

indeed, many thanks. It helps a lot to have an external point of view sometimes :)

Post your Answer

You must be logged in to post an answer.