Posted on March 22, 2017 8:04 am
 |  Asked by Larry Acuna
 |  2144 views
RESOLVED
0
0
Print Friendly, PDF & Email

Good night

I was trying to activate ip multicast-routing on a VRF different that the default but the command ip multicast-routing vrf <name> is not accepted on my switch, I was using a Arista 7280 with the eos version 4.17.1F.

The switch doens´t support this option?

Thanks

 

0
Posted by preetham
Answered on March 22, 2017 8:12 am

Hi Larry,

Enabling multicast on a VRF is bit different than enabling ip routing on vrf. It can be done as shown below.

switch(config)#router multicast
switch(config-router-multicast)#?
ip Global IP configuration commands
vrf Configure multicast for a VRF

switch(config-router-multicast)#vrf ?
WORD VRF name

switch(config-router-multicast)#vrf test
switch(config-router-multicast-vrf-test)#?
ip Global IP configuration commands
—————————————-

switch(config-router-multicast-vrf-test)#ip ?
mfib Multicast FIB
mroute Manage IP static multicast routes
multicast Multicast routing commands
multicast-routing General multicast routing configuration commands
route Manage static routes

The following link should be of some help to get you started with.
https://eos.arista.com/eos-4-15-2f/pim-vrf/

0
Posted by Upasana Dangi
Answered on March 22, 2017 8:12 am

Hi Larry,

We can use the following syntax to enable multicast routing within a VRF:

router multicast
vrf test
ip multicast-routing

In addition, the following link is a good reference for configuring multicast inside VRF:

https://eos.arista.com/eos-4-15-2f/pim-vrf/

0
Posted by Larry Acuna
Answered on March 22, 2017 3:29 pm

Thanks alot for the responses, I will try them and let you know how they work.

Have a great day.

0
Posted by Larry Acuna
Answered on March 22, 2017 10:00 pm

Thanks for the responses, the commands indicates works flawless for me.

Have a good day!

0
Posted by Carlos Zuluaga
Answered on September 24, 2018 1:27 pm

Hello, I have a mlag of 2 switch and I need to configure multicast in a vlan I would appreciate the help.
Thank you

EOS 4.18.0F

Post your Answer

You must be logged in to post an answer.