Posted on July 24, 2020 6:55 pm
 |  Asked by Christopher
 |  53 views
0
0
Print Friendly, PDF & Email

I’m trying to enable IPv6 on a vlan and want hosts to use DHCP and not auto-configure their own address.  I’ve read the documentation and I believe what I have is correct, however the interface still says “Hosts use stateless autoconfig for addresses.”

Doing a packet capture on a host does show it using DHCP to acquire a v6 address so I’m inclined to believe the interface saying that hosts will use stateless autoconfig is just a cosmetic error, but I want to make sure this is correct.  I’m running version 4.24.1.1F of EOS.

My interface has the following:

#sh run int vlan 3 | inc ipv6
ipv6 dhcp relay destination <dhcp server 1>
ipv6 dhcp relay destination <dhcp server 2>
ipv6 address <prefix>::1/64
ipv6 nd managed-config-flag
ipv6 nd prefix <prefix>/64 no-autoconfig

And checking the IPv6 interface:

#sh ipv6 int vlan 3 | inc Host
Hosts use stateless autoconfig for addresses.

Have I done something wrong here?

0
Posted by Kenneth Finnegan
Answered on July 27, 2020 6:37 pm

Howdy Christopher,

I've been playing with this a little bit this morning, and it's not quite clear to me what that "Hosts use..." line is referring to, functionally. I was able to recreate the same issue you were seeing where it still displayed "Hosts use stateless autoconfig for addresses.", but I was able to use tcpdump to confirm that while that was always displayed, the ICMPv6 Prefix Information Autonomous address-configuration flag (Type 3 flag A) in the route advertisements were correctly following the no-autoconfig setting on the ipv6 nd prefix line, so I don't think you've done anything wrong. Does the final functionality behave how you expect, or is there a behavior issue as well?

Post your Answer

You must be logged in to post an answer.