Posted on May 14, 2018 4:15 pm
 |  Asked by David Ron
 |  439 views
Tags:
RESOLVED
0
0
Print Friendly, PDF & Email

Hi
I’m trying to establish isis between a cisco router, IOS-XR and 7280CR running 4.20.5F
adjacency won’t come up.
MTU on cisco side is 9216.
on Arista side, IP MTU is configured as 9202. Layer2 MTU cannot be configured on this platform.
hello-padding is disabled on both ends.

I have 7280SR running an earlier version that works with the same cisco with the same configs.

Has anyone had such problems with isis in 4.20.5F?

0
Posted by Stuti Gor
Answered on May 14, 2018 6:21 pm

Hi David,

Can you configure the IP MTU to be the same on both Arista and Cisco and see if that helps? If the neighborship does not come up, we recommend you to open a TAC case at support@arista.com.

0
Posted by Rohan Kapadia
Answered on May 15, 2018 7:20 pm

Hello David,

As investigated via TAC case, the issue turned out to be capabilities advertised by both the switches:
Cisco was advertising v4 and v6 in IS-IS PDU:
Protocols Supported (t=129, l=2)
Type: 129
Length: 2
NLPID(s): IP (0xcc), IPv6 (0x8e)

We were advertising only v4:
Protocols Supported (t=129, l=1)
Type: 129
Length: 1
NLPID(s): IP (0xcc)

Turning on v6 capability in IS-IS solved the issue.

Thank you!

Hi Rohan,
Thanks again for your support and help. it has been most helpful.

(David Ron at May 18, 2018 6:27 am)
0
Posted by David Ron
Answered on May 18, 2018 6:31 am

Hi
As seen by Rohan during the TAC session, there was a need to configure the v6 address family under isis, and enable multi-topology under it.
The Cisco end sends both v4 and v6 capabilities, even if it’s not enabled on the isis section under the interface.
regarding MTU, it’s 9202 on the arista side, and 9216 (+14 byte) on the cisco side.

Rohan, thanks once again

Post your Answer

You must be logged in to post an answer.