Posted on August 21, 2020 7:28 pm
 |  Asked by Yanluis Hiciano
 |  118 views
RESOLVED
0
0
Print Friendly, PDF & Email

Hello,

We have a BGP peer with a Cisco device, i need to deploy a L3VPN scenario, the configurations seems very straight forward but for some reason we’re not able to ping from a VRF.

We have all the routes coming from our BGP peer to that VRF and we have our Loopback IP add announced to our BGP Peer. When i try to ping it shows the following error

ARISTAPPASBR01#ping vrf MGMT 192.168.222.151 source 192.168.222.168
PING 192.168.222.151 (192.168.222.151) from 192.168.222.168 : 72(100) bytes of data.
ping: sendmsg: Invalid argument
ping: sendmsg: Invalid argument
ping: sendmsg: Invalid argument
ping: sendmsg: Invalid argument
ping: sendmsg: Invalid argument

--- 192.168.222.151 ping statistics ---
5 packets transmitted, 0 received, 100% packet loss, time 40ms

Also we’ve tried that configuration on a virtual lab using vEOS and the result is the same between Cisco and Arista as well as two Arista devices, . We have a working environment with Cisco devices right now and i have tested the same between Mikrotik and Cisco and it works fine.

 

This is the current configuration we have on the Arista Switch DCS-7280SR2A-48YC6

 

-----------INTERFACES---------
interface Loopback222
   vrf forwarding MGMT
   ip address 192.168.222.168/32

--------BGP CONFIG------------

ARISTAPPASBR01#sh run | sec bgp
router bgp 264750
   router-id 172.30.0.18
   no bgp default ipv4-unicast
   neighbor 172.30.0.1 remote-as 264750
   neighbor 172.30.0.1 update-source Loopback0
   neighbor 172.30.0.1 send-community standard extended
   neighbor 172.30.0.1 maximum-routes 12000
   !
   address-family vpn-ipv4
      neighbor 172.30.0.1 activate
      neighbor default encapsulation mpls next-hop-self source-interface Loopback0
   !
   vrf MGMT
      rd 172.30.0.18:22
      route-target import vpn-ipv4 264750:22
      route-target export vpn-ipv4 264750:22
      redistribute connected
	  
-----------VRF MGMT----------------

VRF: MGMT

 B I      192.168.222.151/32 [200/0] via 172.30.0.1/32, LDP tunnel index 7, label 30
                                        via 172.20.0.253, Ethernet45, label imp-null(3)
0
Answered on August 22, 2020 8:50 am

Hi Yanluis,

Thanks for reaching out.

Could you please attach the tech-support log from the Arista device as it will be very helpful in giving all the necessary information we need to investigate this.

show tech-support | no

show tech-support bgp | no

Also is there any end host device connected to 7280SR2A device and are you able to ping from end-host to end-host in VRF MGMT?

Thanks,

Bhavana.

0
Posted by Yanluis Hiciano
Answered on August 22, 2020 2:57 pm

We found a workaround, in order for it to work  an interface has to be configured on that vrf other than the Loopback, so we configured a SVI just to have another valid interface and it started forwarding traffic. I don't know if it's supposed to work like that.

0
Answered on August 22, 2020 5:10 pm

Hi Yanluis,

Yeah the workaround is  to have/configure either Physical L3 interface or SVI for VRF MGMT with 'no autostate' command.

Even though Loopback  interface is a L3 interface , the ping is not getting initiated due to the difference in the programming of the routes when only Loopback interface for that VRF  is configured vs workaround i.e to have either SVI or L3 Physical interface for the VRF.

 

Thanks,

Bhavana.

Post your Answer

You must be logged in to post an answer.