Posted on December 1, 2017 8:45 pm
 |  Asked by Mario Mancini
 |  8882 views
RESOLVED
0
0
Print Friendly, PDF & Email

Hi,

We are creating  port-channel with Arista 7280 and a Cisco switch.

The topology is:

Arista are Et25/1 – Et26/1 <=====> Cisco eth1/31 – eth1/32

The configuration:

ARISTA

interface Ethernet25/1
   channel-group 10 mode active  <–Try also passive
interface Ethernet26/1
   channel-group 10 mode active <– Try also passive

!
interface Port-Channel10

Cisco <—– I can’t access on it

Normal
0

14

false
false
false

IT
X-NONE
X-NONE

/* Style Definitions */
table.MsoNormalTable
{mso-style-name:”Tabella normale”;
mso-tstyle-rowband-size:0;
mso-tstyle-colband-size:0;
mso-style-noshow:yes;
mso-style-priority:99;
mso-style-parent:””;
mso-padding-alt:0cm 5.4pt 0cm 5.4pt;
mso-para-margin:0cm;
mso-para-margin-bottom:.0001pt;
mso-pagination:widow-orphan;
font-size:11.0pt;
font-family:”Calibri”,sans-serif;
mso-ascii-font-family:Calibri;
mso-ascii-theme-font:minor-latin;
mso-hansi-font-family:Calibri;
mso-hansi-theme-font:minor-latin;
mso-bidi-font-family:”Times New Roman”;
mso-bidi-theme-font:minor-bidi;
mso-fareast-language:EN-US;}

interface Port-channel 1

switchport

switchport mode access

switchport access vlan 1

lacp suspend-individual

no shutdown

!

interface Eth1/31-32

switchport

switchport mode access

switchport access vlan 1

channel-group 1 mode active

no shutdown

!!!!!!

LACP works fine with only on the first interface Et25/1 <==> eth1/31

But it’s does’t work on second one (Et26/1 <==> eth 1/32), either in pairs or alone.

And in the log is possible read:
Dec 1 14:26:38 CAL-LEAF1 Lag: %LACP-4-PARTNER_CHURN: LACP Partner Churn Detected on Ethernet26/1
Dec 1 14:26:38 CAL-LEAF1 Lag: %LACP-4-ACTOR_CHURN: LACP Actor Churn Detected on Ethernet26/1
I looked for the meaning of this log, on Arista's site, on sysmsgguide, on Internet but without success.
Somebody could explain me the meaning of this logging messages?


Thanks in advance,

Mario 

 

1
Posted by manasi gupta
Answered on December 7, 2017 10:13 am

Hi Mario,

The following log indicates that the LACP could not come to a decision on an aggregate (port-channel 10).

Dec 1 14:26:38 CAL-LEAF1 Lag: %LACP-4-PARTNER_CHURN: LACP Partner Churn Detected on Ethernet26/1 

The Recommended Action will be to check the following.

1) Investigate the LACP configuration on this system and its peer.

2) Ensure that all ports in the aggregate are connected to the same remote system, and are all configured to be in the aggregate on the remote system.

3) If not associated with simultaneous actor churn, check if the remote system has aggregation limits that prevent this port from joining the aggregate.

To further get the relevant help for your issue, I would suggest you dropping an email to support@arista.com with brief description of the problem.

Hello Mario, Did you get the issue resolved ? I am in the same situation, same MLAG platform and Cisco
(ashutosh sharma at May 13, 2020 9:55 am)
Hi Ashutosh,

To kickstart if you can share
1. Rough topology
2. Config check for MLAG and LACP
TOI: https://eos.arista.com/mlag-basic-configuration/
3. It is always recommended to use dynamic LACP mode vs static i.e mode on
4. If 2 and 3 = GOOD/OK, I would look at the summary of port-channel, counters.
Commands to check:

    show port-channel summary
    show port-channel all-ports
    show port-channel all-ports detailed
    show lacp counters all-ports detailed
    show lacp internal all-ports detailed


5. We have LACP T-shoot TOI as well:https://eos.arista.com/troubleshooting-lacp/

Look forward to your response

Sincerely,
Shreyas Ruwala

(Shreyas Ruwala at May 14, 2020 7:03 pm)
Hi Ashutosh, A quick follow-up to know if any of the above steps helped to resolve the LACP issue observed I look forward to your response Sincerely, Shreyas Ruwala TAC-ECC
(Shreyas Ruwala at June 19, 2020 3:13 pm)

Post your Answer

You must be logged in to post an answer.