Posted on April 21, 2020 5:27 pm
 |  Asked by Tim Wiederkehr
 |  126 views
0
0
Print Friendly, PDF & Email

Hello Together

 

I try to set up LACP From the 7050S to the ESXI hosts. Way is the LACP not working ? ESXI is set to Rout based on IP Hash.

This is my settings:

vlan 10
name temp_10
!
interface Port-Channel10
switchport access vlan 10
switchport mode trunk

!
interface Ethernet1
switchport mode trunk

 

interface Ethernet17
switchport mode trunk
channel-group 10 mode active
!
interface Ethernet18
switchport mode trunk
channel-group 10 mode active

 

Thanks in advance.

Tim

0
Posted by Kevin Malone
Answered on April 21, 2020 6:10 pm

I thought lacp wasn't supported on esxi.  I could be wrong though...

0
Answered on April 21, 2020 7:01 pm

Hi Tim.

I noticed the port-channel10 configuration is set as 'access' and 'trunk'. Based on the interface et17 and 18 configuration, I supposed the port-channel should be a trunk port as well.

If this is the case you could remove 'switchport access vlan 10' config from the port-channel10 and check the outputs for the following commands:

show interfaces switchport - check the detailed view of the port config including if it is an access, trunk port, etc.

show interfaces trunk - check which vlans are being carried through the port and also, if they are in STP forwarding.

show spanning-tree vlan 10 - check the current status of STP for this particular vlan.

 

1
Posted by joe-d
Answered on April 24, 2020 2:55 pm

Hello Tim,

Based on this:

 

interface Ethernet17
switchport mode trunk
channel-group 10 mode active
!
interface Ethernet18
switchport mode trunk
channel-group 10 mode active

You'd be well served with this tcpdump via the bash shell

tcpdump -nei et17 ether proto 0x8809 -c 30
tcpdump -nei et18 ether proto 0x8809 -c 30

the "-c" is a count of 30, that should suffice in terms of number of packets to look at/for when debugging.  With that you can see what's happening @ the PDU level.

If you don't see LACP PDUs coming from the ESXi box that's where to look.

If you see bidirectional PDUs then from EOS you'd want to look at/into the following CLIs

show lacp X neighbor (see if consistent/common)

clear lacp counters
show lacp X counters all-ports (check for linearity of tx/rx pdus)
show port-channel summary

--
joe

Post your Answer

You must be logged in to post an answer.