Posted on May 11, 2020 9:10 am
 |  Asked by Robbie Reynolds
 |  332 views
Tags:
RESOLVED
0
0
Print Friendly, PDF & Email

Hoping to get some assistance on the below.

Switch models: Arista 7050Qx-32S.

We’re attempting to setup an MLAG between the two switches. The current issue we are facing, is that one switch respects the ‘switchport mode trunk’ command, while the other does not. Regardless of what is done, the second switch port group stays in ‘routed’, then when attempting to assign it to an MLAG ID, it states that it is required to be a trunk.

We’re following: https://www.arista.com/en/um-eos/eos-section-13-4-configuring-mlag#ww1151451

Any help would be appreciated, it seems that no matter what we do it will not change from routed to trunk.
An off-note, that also on the same switch, when attempting to assign a VLAN an IP address, it shows an error of ‘Ip address cannot be a broadcast address’, which it isn’t. The other switch, with the same commands did not show either of these errors.

Attempted: reboot, re-creation of peer, port group etc.

Thanks!

0
Answered on May 11, 2020 9:27 am

Hi Robbie.

Would it be possible to confirm the software version and also provide the following output from the affected switch?

show running-config interface [int-name]
show interfaces [int-name] switchport
show interfaces [int-name] vlans
show interfaces [int-name] trunk
show mlag
show mlag config-sanity

These outputs should help us analysing this further.

 

0
Posted by Aniket Bhowmick
Answered on May 11, 2020 9:33 am

Hi Robbie,

For the first issue- "One switch respects the ‘switchport mode trunk’ command, while the other does not."

  • Can you confirm if you had configured the interface as "routed interface" as shown below:
    • (config-if-Et7/1)#sh active
      interface Ethernet7/1
      no switchport
  • If that is the case, then if you try to enter the "switchport mode trunk command", the command will not take effect as the interface is still configured as "no switchport" (routed)
  • What you need to do now is, just enter the following command: "switchport" under the corresponding interface (Let us know if you had already tried that and still it doesn't work) as shown below::
    • (config-if-Et7/1)#switchport
  • Now do "switchport mode trunk" :
    • (config-if-Et7/1)#switchport mode trunk
  • After this the interface should become part of all Vlans:
    • config-if-Et7/1)#sh vlan 100
      VLAN Name Status Ports
      ----- -------------------------------- --------- -------------------------------
      100 VLAN0100 active Et7/1, Et33/1

For Second issue: "that also on the same switch, when attempting to assign a VLAN an IP address, it shows an error of ‘Ip address cannot be a broadcast address’, which it isn’t"

  • Can you share the IP you are configuring ? Best if you share the "show running-config" output

Thanks,

Aniket

0
Posted by Robbie Reynolds
Answered on May 11, 2020 11:10 pm

Hi All,

The above worked, the ports weren't in 'switchport' mode, but on the second switch apparently were out-of-the-box.

The IP addressing issue was caused by me, which is now fixed.

Thanks all for the quick remediation advice.

 

0
Posted by Robbie Reynolds
Answered on May 13, 2020 6:33 am

To continue this, we're still having MLAG issues, namely we can setup an MLAG fine, it shows Active to the second switch.

"MLAG Status:
state : Active
negotiation status : Connected
peer-link status : Up
local-int status : Up
system-id : 76:83:ef:13:71:2f

MLAG Ports:
Disabled : 0
Configured : 0
Inactive : 0
Active-partial : 0
Active-full : 0"

We just cannot assign interfaces to the MLAG, with the error 'Port-channel already configured as peer-link'.

So therefore there are no interfaces within the MLAG, as seen above.

Any ideas?

 

0
Posted by Aniket Bhowmick
Answered on May 13, 2020 10:22 am

Hi Robbie,

Which port-channel are you trying to configure it as MLAG port-channel? Is it the peer-link itself ?

A peer-link will be the port-channel (or a normal interface) that connects the two switches which are in MLAG. You should not configure that port-channel as a MLAG Port-channel. The purpose of peer link is to maintain the state of MLAG, Synch layer2 information between the 2 switches and provide a redundant path related to traffic forwarding of end hosts.

A MLAG port-channel is one that will connect both the switches (in MLAG) to a same downstream server or end host and would provide active-active paths (also it will be loop free). Active-Active means the downstream connected server can send traffic to either of the peer but both the switches can forward traffic. This is good for redundancy as if any one link goes down, server can still send packet to other connected switch and there will be no packet loss.

So you can have a setup like this:

[SW1]po1----------po1[SW2]

Po1 in above topology is the peer link. You should not try make Po1 as a MLAG port-channel.

Now consider, there is an interface "Ethernet 10" on both the switches (SW1 and SW2) that connects to some server (same server), not shown in above diagram.

Then you can combine Eth10 on both switches as a MLAG port-channel. First you need to configure port-channel on Eth10 of both the device:

(config-if-Et10)#channel-group 10 mode active.       
^ the channel-group id can be anything between 1-2000. Also, it must be done on both switches

Once you assigned Eth10 to port-channel 10 on both switches, then assign the MLAG id on po10 of both the device as shown below

(config)#int po 10
(config-if-Po10)#mlag 10

^ The "mlag 10" should be exactly same on Po10 of both SW1 and SW2 (id can be anything but must be same on both), only then Po10 on both switch will be logically be one link. This is known as MLAG port-channel.

You can check your MLAG port-channel using the command- "show mlag interfaces"

Let me know what configuration you are entering and if it is according to the concept mentioned above or not.

For more details, check here- https://eos.arista.com/mlag-basic-configuration/

Thanks,

Aniket

0
Posted by Robbie Reynolds
Answered on May 13, 2020 11:42 pm

Thanks for the above Aniket.

One last question, can we assign all ports with SW1 to the same port channel and Mlag ID, and do the same on SW2?
Or does it have to be separate port channels and mlag's for each server?

 

Thanks!

0
Posted by Aniket Bhowmick
Answered on May 15, 2020 8:37 am

Hi Robbie,

MLAG port-channel is formed if both (or more) interfaces on the two switches (in MLAG) receives LACP packets sourced from same System ID/mac.

So if   "SW1-----SW2" are in MLAG and both have Ethernet10 on them that connects to different servers, then the Ethernet10 on SW1 will receive a LACP packet sourced from mac address of Server1 (connected to Ethernet10 of SW1) and Ethernet10 on SW2 will receive LACP Packets from mac address of Server2 (that is connected to Ethernet10 of SW2). Due to this Ethernet10 on both switches cannot become one logical link (MLAG port-channel) as they receive the LACP packets with different mac addresses.

So if all your interfaces on both switches connect to same physical server, such that all the interfaces on both switches receive LACP packets with same source mac, then yes you can put all those interfaces as part of one MLAG port-channel, but it seems very unlikely that all interfaces would to same physical server.

Regards,

Aniket

0
Posted by Robbie Reynolds
Answered on May 18, 2020 5:16 am

To add to this, we've just added just as you've mentioned above, with:
int eth 20/1
channel-group 20 mode active (also tried passive)
int po 20
mlag 20

 

show mlag interfaces shows

mlag desc state local remote status
---------- ---------- -------------- ----------- ------------ ------------
20 inactive Po20 Po20 down/down

The server is plugged into both switches, which each have identical configurations.

Each of the mlag port's is showing the same on each switch, which is inactive and shows as the above.

Any ideas?

 

 

0
Posted by Roberto Salazar
Answered on May 26, 2020 8:24 pm

Hi Robbie,

Can you share the following outputs:

show port-channel 20

show lacp neigh

show port-channel summary

show run interface port-channel 20

show run | grep -i "channel-group 20"

show interface port-channel 20

 

The port-channel being down could mean:

  1. Arista switch configuration is not complete.
  2. Servers are not configured for port-channel.
  3. Servers are not sending lacpdu

 

Post your Answer

You must be logged in to post an answer.