Posted on May 1, 2015 3:11 pm
 |  Asked by Roland Wyss
 |  1349 views
RESOLVED
-2
0
Print Friendly, PDF & Email

I created a MLAG. Everything is working well.

But when I create a VLAN on the primary node, the VLAN doesn’t get created automatically on the secondary node.

Here (https://eos.arista.com/mlag-basic-configuration/) I red the following:

  • A VLAN created only on the primary will be present on the secondary when the MLAG devices are active (primary/secondary) but will go away if the MLAG association is broken.

 

Here’s output from sh mlag detail:

SWITCH1:

MLAG Configuration:

domain-id : mlagdom1
local-interface : Vlan4094
peer-address : 172.30.29.1
peer-link : Port-Channel1

MLAG Status:
state : Active
negotiation status : Connected
peer-link status : Up
local-int status : Up
system-id : 02:1c:73:b4:59:23

MLAG Ports:
Disabled : 0
Configured : 0
Inactive : 0
Active-partial : 0
Active-full : 0

MLAG Detailed Status:
State : primary
State changes : 3
Last state change time : 0:36:43 ago
Hardware ready : True
Failover : False
Last failover change time : 0:32:56 ago
Secondary from failover : False
primary-priority : 32767
Peer primary-priority : 32767
Peer MAC address : 00:1c:73:b4:59:23
Reload delay : 300 seconds
Non-MLAG reload delay : 300 seconds
Peer ports errdisabled : False
Lacp standby : False
Configured heartbeat interval : 4000 ms
Effective heartbeat interval : 4000 ms
Heartbeat timeout : 60000 ms
Last heartbeat timeout : never
Heartbeat timeouts since reboot : 0
Peer monotonic clock offset : -8623.976516 seconds
Agent should be running : True
P2p mount state changes : 3

 

SWITCH2:

MLAG Configuration:
domain-id : mlagdom1
local-interface : Vlan4094
peer-address : 172.30.29.2
peer-link : Port-Channel1

MLAG Status:
state : Active
negotiation status : Connected
peer-link status : Up
local-int status : Up
system-id : 02:1c:73:b4:59:23

MLAG Ports:
Disabled : 0
Configured : 0
Inactive : 0
Active-partial : 0
Active-full : 0

MLAG Detailed Status:
State : secondary
State changes : 2
Last state change time : 0:33:47 ago
Hardware ready : True
Failover : False
Last failover change time : never
Secondary from failover : True
primary-priority : 32767
Peer primary-priority : 32767
Peer MAC address : 00:1c:73:b4:59:bf
Peer MAC routing supported : False
Reload delay : 300 seconds
Non-MLAG reload delay : 300 seconds
Ports errdisabled : False
Lacp standby : False
Configured heartbeat interval : 4000 ms
Effective heartbeat interval : 4000 ms
Heartbeat timeout : 60000 ms
Last heartbeat timeout : never
Heartbeat timeouts since reboot : 0
Peer monotonic clock offset : 8623.972164 seconds
Agent should be running : True
P2p mount state changes : 1

 

SWITCH1:

VLAN Name Status Ports
—– ——————————– ——— ——————————-
1 default active Po1
49 inet_tfn active Po1
444 VLAN0444 active Po1
4094 MLAG active Cpu, Po1

 

SWITCH2

VLAN Name Status Ports
—– ——————————– ——— ——————————-
1 default active Po1
49 inet_tfn active Po1
4094 MLAG active Cpu, Po1

0
Posted by ma
Answered on May 4, 2015 9:10 pm

Hi Roland,

Currently we don’t synchronise the VLAN databases between two MLAG peers.

We will be updating the MLAG Basic Configuration post accordingly.

Thank you for your pointer.

Kind regards,

-Michael

 

 

Post your Answer

You must be logged in to post an answer.