Posted on October 19, 2018 8:59 pm
 |  Asked by Warren Granada
 |  473 views
Tags:
RESOLVED
0
0
Print Friendly, PDF & Email

I am trying to troubleshoot an multicast issue with the group IP of 239.4.1.58 but when I enter the following commands
at the FHR I get nothing

sh ip igmp group 239.4.1.58
sh ip mroute 239.4.1.58
sh ip mfib 239.4.1.58

when I ask if there is a group that is working they told me 239.4.1.39
but when I enter the above commands for the .39 I don’t see anything
why is that?

I tried a different mcast group that I found was working 239.18.1.113
when I enter the same commands I get information. I just don’t see anything
for the 239.4.1.39 or 58 groups. Am I doing something wrong?

Thank you in advance!!!

0
Posted by Aks e Zehra
Answered on October 22, 2018 11:54 am

Hi Warren,

Could you please check if there are any vrf configurations on the switch. For the working group, 239.4.1.39 if this router is the FHR and the mcast feed/pim-hello/joins are being received on an interface belonging to a non-default vrf then it won’t be visible under the default one. For checking the output under non-default vrf, you can use the following commands:
sh ip igmp vrf group 239.4.1.39
sh ip mroute vrf
239.4.1.39
sh ip mfib vrf
239.4.1.39

After the above check, if you are not seeing the state under “show ip mroute” or “show ip mfib” then please perform the following checks:
– pim is enabled on the interface that is towards the source. Check “show ip pim interface”. If the interface facing the Mcast feed is not pim enabled then the multicast traffic will just get flooded in the local VLAN and no mroute state will be formed.
– route to the source IP is present in the routing table. Check “show ip route”. If the RPF check fails then the mroue will have “null” interface under IIF.

To see the states populated under “show ip igmp group” on the FHR, the OIL should be a VLAN with SVI configured. Also, please check if the VLAN has IGMP snooping enabled. Check “sho ip igmp snooping vlan .

Thank you,
Aks

0
Posted by Warren Granada
Answered on October 22, 2018 2:57 pm

I solved the issue, the .58 had a specific entry for the RP that was pointing to a dead RP IP
once I removed that that fixed my issue

Post your Answer

You must be logged in to post an answer.