Posted on June 8, 2020 5:56 pm
 |  Asked by Roman Banishevsky
 |  140 views
Tags:
RESOLVED
0
0
Print Friendly, PDF & Email

Hi all! I need some help with multicast on EOS.

I have an Arista DCS-7050S-64-F with EOS version 4.18.11M

The Arista is connected to the Juniper QFX via PIM and OSPF (vlan 3025). Vlan 7 is multicast vlan for our multicast receivers from L2 domain.

I receive all RPs from PIM neighborhood. But I can’t see multicast if subscribe to multicast group from undirected network (any network which unknown for the Arista). And PIM-Join is not send  from the Arista to the Juniper.

If I subscribe from directly connected network (vlan7) I see multicast TV.

What should I do in order to subscrbibe to multicast from any networks?

 

The Arista config:

ip igmp snooping vlan 7 querier version 2
ip igmp snooping vlan 7 immediate-leave

interface Ethernet1
switchport trunk allowed vlan 3025
switchport mode trunk

interface Ethernet5
speed forced 1000full
switchport trunk allowed vlan 7,10,12,500
switchport mode trunk
ip igmp version 2

interface Loopback1
ip address 172.30.127.24/32
!

interface Vlan7
description IPTV_for_local_abon
ip address 172.30.136.241/29
ip igmp version 2
ip pim sparse-mode
!

interface Vlan3025
description OSPF and PIM with QFX
ip address 172.30.128.34/30
ip ospf network point-to-point
ip pim sparse-mode

ip routing
!

!
router multicast
ip multicast-routing
!
router ospf 1
router-id 172.30.127.24
passive-interface default
no passive-interface Vlan3025
network 172.30.127.24/32 area 0.0.0.0
network 172.30.128.32/30 area 0.0.0.0
max-lsa 12000
maximum-paths 32
!
router pim sparse-mode
ip pim sparse-mode sg-expiry-timer 120
ip pim rp-candidate Loopback1 239.0.0.2/32 priority 200
!
router pim bsr
ip pim bsr-candidate Loopback1 224.0.0.0/4 priority 10 hashmask 30 interval 60
!

 

Attachments:
0
Posted by Aniket Bhowmick
Answered on June 9, 2020 3:37 am

Hi Roman,

So all users in Vlan 7 can subscribe to the Multicast Group and can receive traffic but not the users that are in other Vlans (example Vlan 10, 12, 500)

From your configuration, we can see "interface vlan 7" but I don't see any "interface vlan" for Vlan 10, 12 and 500 (no SVIs), assuming those are the undirected networks you were talking about.

Is the Arista switch acting as pure Layer2 (only bridging) for the Vlan 10, 12 and 500 ?

If Yes, then:

  • are you sure the switch is receiving the IGMP reports from the hosts that are present in those Vlans (10, 12 and 500) ? Check it using the command- "show ip igmp snooping groups vlan <id>"
  • Is IGMP snooping enabled (it is enabled by default). Check it using "show ip igmp snooping vlan <id>"
  • For Vlan 10, 12 and 500, who is the querier in the network (that would create the *,g mroute) ?
  • Can you run the command- "show ip igmp snooping mrouter vlan <id>" and check if you can see a mrouter port for Vlan 10, 12 and 500. If there is no mrouter port but IGMP snooping is enabled, then that is what is causing the issue as IGMP reports sent by host would never reach the Querier

How Layer2 Multicast would work:

  • Hosts should send IGMP Reports that would reach the Arista L2 switch. The Arista L2 would snoop those IGMP reports (snooping is enabled by default) but snooping will not work (though it is enabled) until and unless the Arista L2 switch receives an IGMP query from the querier.
  • Arista L2, after receiving the IGMP report from the host, would then check where is the querier connected in that Vlan. Querier will be connected on the port which will show up as mrouter port in "show ip igmp snooping mrouter vlan <id>". When Arista L2 receives a IGMP query from querier, it marks that interface as mrouter port which indicates the querier is connected on that port.
  • If mrouter port is present, Arista L2 would forward the IGMP Report (sent by host) towards the querier via the mrouter port.
  • Querier would receive those IGMP report messages and will for the *,G mroute state from where it has to send the uplink PIM join towards RP.

If Arista is not supposed to be L2 for Vlan10, 12 and 500, then you need to create SVI for those Vlan and have to enable PIM sparse-mode on them.

Let us know if there is something we understood incorrectly.


Regards,

Aniket

Hi Aniket!

Thanks for you answer Switch is working in bridge mode for vlans 10,12,500. Only vlan 7 is multicast vlan.

For example, if I subscribing from source address 172.30.136.242/29 (direct network on vlan 7), multicast is working and I see PIM-join to my Juniper.

SG-Arista-Spine#show ip igmp snooping groups vlan 7 detail
Vlan Group           IP              First       Last        Expire   Ver Filter Port
                                     Heard       Heard                    Mode      
-------------------------------------------------------------------------------------
7    239.72.6.21     172.30.136.242  0d00h00m06  0d00h00m06  00h04m14 v2  0   Et16/1
7    239.72.6.21     172.30.136.241  0d00h26m52  0d00h00m19  00h01m26 -   -  Cpu


But if I subscribing from any source address (ex: 10.100.255.254) in vlan 7, multicast is not working and PIM-join is not transmitting from Arista to Juniper:

SG-Arista-Spine#show ip igmp snooping groups vlan 7 detail
Vlan Group           IP              First       Last        Expire   Ver Filter Port
                                     Heard       Heard                    Mode      
-------------------------------------------------------------------------------------
7    239.72.6.152    10.100.255.254  0d00h00m02  0d00h00m02  00h04m18 v2  0   Et16/1
7    239.72.6.152    172.30.136.241  0d00h25m41  0d00h00m08  00h01m37 -   -  Cpu

For example,

in Extreme Switches it's problem can be fixed with command configure pim add vlan sparse passive

in Juniper Switches with command set protocols igmp interface

(Roman Banishevsky at June 23, 2020 9:07 am)
1
Answered on June 24, 2020 9:12 pm

Thanks Roman.

I can see that you only have problems when the source address for the subscribers do not match the subnet for the interface VLAN they are connected to. In this example:

  • 172.30.136.242 matches 172.30.136.241/29 and works
  • 10.100.255.254 does not match 172.30.136.241/29 and does not work

One command that you can try configuring on the VLAN interface is  the following:

ip igmp router-alert optional

The default is optional connected, which will allow IGMP from non-matching sources only if router-alert is set.

Here is more info:

https://www.arista.com/en/um-eos/eos-section-39-6-igmp-and-igmp-snooping-commands#ww1143351

I hope this helps!

Pedro

Yes! It works!!! Thank you!!!
(Roman Banishevsky at June 25, 2020 4:51 am)
0
Answered on June 25, 2020 10:44 am

Glad it worked Roman. Thanks for using Arista!

P

Post your Answer

You must be logged in to post an answer.