Posted on September 25, 2019 7:23 pm
 |  Asked by elukss
 |  234 views
Tags:
0
0
Print Friendly, PDF & Email

Hello,

In my lab I have 2xDCS-7050S-52-F configured in MLAG.
In default vrf I configured ospf, all is working fine:

> sh running-config section ospf
interface Vlan4093
ip address 10.10.0.253/30
ip ospf bfd
ip ospf hello-interval 30
ip ospf network point-to-point
!
router ospf 100
router-id 10.10.1.201
auto-cost reference-bandwidth 40000
passive-interface default
no passive-interface Vlan4093
redistribute connected
redistribute static
area 0.0.0.0 default-cost 110
network 10.10.0.252/30 area 0.0.0.0
max-lsa 12000
graceful-restart

Now I decide to configure new vrf’s.
Question – how is correct way to redistribute vrf routes between switches in all vrf’s using ospf?

Thanks.

0
Posted by Prithvish Nembhani
Answered on October 22, 2019 9:03 am

Hi Elukss,

From what I understand you have a peering in default vrf at the moment and you wish to distribute routes received in other vrf over the peering in default vrf.

From a high level, I could think of 2 ways to achieve.
1. Create an OSPF peering in different vrfs and distribute routes.
2. Leak specific routes from a vrf to another.

Following a certain ways to achieve the second solution.
https://eos.arista.com/eos-4-22-1f/eos-vrfleak-agent/
https://eos.arista.com/eos-4-22-1f/inter-vrf-local-connected-route-leaking/
https://eos.arista.com/eos-4-22-0f/bgp-vpn-and-inter-vrf-local-route-leaking-support-for-default-vrf/

For the first solution, you can refer to the user manual.
https://www.arista.com/en/um-eos/eos-open-shortest-path-first--version-3

The methods suggested were recently introduced in EOS and might require a recent code release.
Would you like to know what code are we running?

If this needs to be discussed further feel free to open up a case with support by writing at support@arista.com

Hope this helps!

Thanks,
Prithvish

Post your Answer

You must be logged in to post an answer.