Posted on May 19, 2019 1:44 am
 |  Asked by Carlo Taddei
 |  358 views
0
0
Print Friendly, PDF & Email

Hi,

I need to configure OSPF peering/adjaciency between 2 Arista Switches ( DCS-7280SRAM-48C6-F, running EOS vers. 4.21.3F-10977770.4213F) in a MLAG Setup. I would like to have the OSPF peering established over the MLAG peer Link.

I have configured a separate VRF for testing and a unique OSPF Routing ID on each of the MLAG peer.

I have attempted to establish the OSPF peering/adjaciency (that is, moving into a FULL STATE and having OSPF Routes exchanged) using SVIs on a dedicated OSPF Transfer VLAN (which should be natively carried over the MLAG Peer Link) – unfortunately without any success; I have also attempted to establish the OSPF peering via loopback interfaces – this also didn’t work so far …

The OSPF state machine is stuck in “EXCHANGE START” and the 2 MLAG Peer members do not get to the FULL STATE.

Most important for my routing setup: the OSPF routes which are learned from the MLAG Peer Member #1 are no where to be seen in the routing table of the MLAG Peer member #2 (there seem to be no synching of the OSPF VRF routing information happening in the “background” …)

What puzzles me is the fact that I have tested this same scenario in GNS3 using the vEOS image 4.21.1F and OSPF peering withing an MLAG Pair (between the 2 MLAG Members) is working flawlessly (the 2 MLAG Peer Members are in an OSPF FULL State).

Am I here missing something when moving from the “virtual” world to the “physical appliance” world ?

Moreover, is this Scenario supposed to be working on the platform that we have (DCS-7280SRAM-48C6-F) and with the EOS SW version 4.21.3F ?

Thanks

0
Posted by Jose Reyes
Answered on May 19, 2019 1:49 am

Hi Carlo.

If possible, having a look at your config would be very useful.

Thanks,

Hi Jose, thank you for your feedback – here’s the sanitized config (only showing the relevant portion of the config)

Relevant Config Portion on the MLAG 1st Member

interface Port-Channel2000
description L2 Link to XXX
switchport mode trunk
switchport trunk group MLAGPEER
!
interface Ethernet49/1
description L2 Link to XXX Member of Port-Channel2000
mtu 9214
logging event link-status
arp timeout 900
channel-group 2000 mode active
!
interface Ethernet50/1
description L2 Link to XXX Member of Port-Channel2000
mtu 9214
logging event link-status
arp timeout 900
channel-group 2000 mode active
!
vlan 999
name TEST-OSPF
!
vlan 4094
name mlag
trunk group MLAGPEER
trunk group mpeer
!
vrf definition TEST
!
interface Vlan999
vrf forwarding TEST
ip address 172.100.100.1/28
!
ip routing vrf TEST
!
router ospf 10 vrf TEST
router-id 80.80.80.80
auto-cost reference-bandwidth 40000
passive-interface default
no passive-interface Vlan999
network 172.100.100.0/28 area 0.0.0.0
max-lsa 12000
!

Relevant Config Portion on the MLAG 2nd Member

interface Port-Channel2000
description L2 Link to XXX
switchport mode trunk
switchport trunk group MLAGPEER
!
interface Ethernet49/1
description L2 Link to XXX Member of Port-Channel2000
mtu 9214
logging event link-status
arp timeout 900
channel-group 2000 mode active
!
interface Ethernet50/1
description L2 Link to XXX Member of Port-Channel2000
mtu 9214
logging event link-status
arp timeout 900
channel-group 2000 mode active
!
vlan 999
name TEST-OSPF
!
vlan 4094
name mlag
trunk group MLAGPEER
trunk group mpeer
!
vrf definition TEST
!
interface Vlan999
vrf forwarding TEST
ip address 172.100.100.2/28
!
ip routing vrf TEST
!
router ospf 10 vrf TEST
router-id 80.80.80.81
auto-cost reference-bandwidth 40000
passive-interface default
no passive-interface Vlan999
network 172.100.100.0/28 area 0.0.0.0
max-lsa 12000
!

Checking OSPF Status: (OSPF Exchange is stuck in Exchange Start -> not reaching the Full state over the MLAG peer link)

Member_01#sh ip ospf neighbor
Neighbor ID VRF Pri State Dead Time Address Interface
80.80.80.81 TEST 1 EXCH START/BDR 00:00:32 172.100.100.2 Vlan999

Member_02#sh ip ospf neighbor
Neighbor ID VRF Pri State Dead Time Address Interface
80.80.80.80 TEST 1 EXCH START/DR 00:00:30 172.100.100.1 Vlan999

!

Please let me know if you need any additional debug / verification inputs in order to troubleshoot thin issue …

I run the same setup in a GNS3 environment and the OSPF peering is working flawlessly over the MLAG peer link …

Thnak you for your help.

(Carlo Taddei at May 19, 2019 1:48 pm)
0
Answered on May 19, 2019 10:20 am

Hi Carlo.

As mentioned by Jose, it would be useful to take a look at the configuration so we can double-check for any inconsistencies. Apart from that, do you see any warning/error messages in the syslog?

Thanks.

Hi Diogo,

The sanitized relevant config is attached above. I do not see any significant log messages as to why the OSPF state machine is stuck in Exchange Start. Any additional ideas what I might be here missing ? thanks

(Carlo Taddei at May 20, 2019 4:17 am)
0
Posted by Michael Pergament
Answered on May 20, 2019 6:41 am

Hi,

do you have VARP IP configured? Then the reason is most probably described here:
https://eos.arista.com/forum/ospf-on-mlag-peers/

Thanks!
Michael

Hi

thank you for your feedback.

I do not have VARP IP configured in the GNS3 environment (for the SVIs defined over the OSPF transfer Vlan where the 2 MLAG members can establish an OSPF peering /neighborship) – so I also did not configure this approach for the OSPF MLAG Peer implementation with the DCS-7280 Series …

Nevetheless I also came across this post on the EOS Forum and attempted to establiish an OSPF peering between the 2 MLAG peers using VARP – unfortunately without any success ….

Moreover, why should there be a difference between the virtual (GNS3-based) world (OSPF Peering over MLAG Link between the 2 MLAG Members working flawlessly) and the physical based world (same config not resulting in an OSPF peering) ?

Do you have any additional suggestion as to where I might search for additional problems ?

Thanks,

(Carlo Taddei at May 20, 2019 10:28 am)
0
Posted by ANURAG MURUGESAN
Answered on May 20, 2019 8:20 am

Hello Carlo,

Do we have IP Connectivity between both the Switches in MLAG in VLAN999? i.e. Are we able we ping 172.100.100.2 from Member_01 and/or 172.100.100.1 from Member_02?

If there is no IP connectivity between both the Switches in MLAG in VLAN999, this could explain why the OSPF peering is not coming up. In this case, the next step would be to resolve the IP reachability issue.

Regards,
Anurag

0
Posted by Thomas Smith
Answered on May 20, 2019 10:38 pm

Carlo,
I recently had a customer experience a similar problem with OSPF adjacencies. Can you please post output of show run section mlag?
–Thom

0
Posted by Upasana Dangi
Answered on May 20, 2019 10:47 pm

Hi Carlo,

Just wanted to check if you have peer routable mac configured on these devices i.e. ip virtual-router mac-address mlag-peer

0
Posted by Naveen Chandra
Answered on May 22, 2019 7:25 am

In addition to Upsana’s response, I faced the same issue where OSPF neighbourship was not coming up across the MLAG peer-link (stuck in exstart). And after removing “ip virtual-router mac-address mlag-peer” from both switches issue got resolved.
The fact is, with this command switch do not pass but consume the packets destine to peer’s physical Mac-address and hence DBD packets never reach to destination.

0
Posted by Naveen Chandra
Answered on May 22, 2019 7:25 am

In addition to Upsana’s response, I faced the same issue where OSPF neighbourship was not coming up across the MLAG peer-link (stuck in exstart). And after removing “ip virtual-router mac-address mlag-peer” from both switches issue got resolved.
The fact is, with this command switch do not pass but consume the packets destine to peer’s physical Mac-address and hence DBD packets never reach to destination.

Post your Answer

You must be logged in to post an answer.