Posted on August 19, 2020 5:19 am
 |  Asked by Carl Taylor
 |  90 views
RESOLVED
0
0
Print Friendly, PDF & Email

Hi All,

Just wondered on the configuration for PIM Anycast-RP.  (I am assuming this can run just in PIM without the need for MDSP).  I am trying to create a redundant RP setup for PIM.

I have 2 switches running PIM and OSPF.  I have configured an anycast-RP set.

Software image version: 4.20.11.1M-2GB

Is this a supported configuration and how do I verify it is working correctly?

switch1#show ip pim anycast-rp

Anycast Rp address is 172.23.39.17

Anycast Peers address is 172.23.39.15

Anycast Peers address is 172.23.39.16

 

switch2#show ip pim anycast-rp

Anycast Rp address is 172.23.39.17

Anycast Peers address is 172.23.39.16

Anycast Peers address is 172.23.39.15

 

Switch 1:

 

switch1#show run | section pim

interface Vlan903

ip address 172.23.37.253/29

ip ospf network point-to-point

ip pim sparse-mode

vrrp 93 priority 105

vrrp 93 ip 172.23.37.252

!

interface Loopback0

ip address 172.23.39.15/32

!

interface Loopback100

ip address 172.23.39.17/32

!

router pim sparse-mode

ip pim rp-address 172.23.39.17 239.255.100.10/32

ip pim anycast-rp 172.23.39.17 172.23.39.15

ip pim anycast-rp 172.23.39.17 172.23.39.16

 

Switch 2:

 

switch2#show run | section pim

interface Vlan903

description VL:903 Transport

ip address 172.23.37.254/29

ip ospf network point-to-point

ip pim sparse-mode

vrrp 93 ip 172.23.37.252

!

interface Loopback0

ip address 172.23.39.16/32

!

interface Loopback100

ip address 172.23.39.17/32

!

router pim sparse-mode

ip pim rp-address 172.23.39.17 239.255.100.10/32

ip pim anycast-rp 172.23.39.17 172.23.39.15

ip pim anycast-rp 172.23.39.17 172.23.39.16

 

Thanks in advance

1
Answered on August 19, 2020 5:26 am

Hi Carl,

Thank you for contacting Arista.

We don't need MSDP peering inorder for Anycast-rp to work and Anycast-rp can just run in PIM.
Also if multiple anycast-rps has been configured we can check if they are working correctly by issuing "show ip pim anycast-rp” command.

Since your device is running 4.20.11.1M-2GB the above configs looks good and valid.For latest EOS versions there is a change in CLI syntax for few multicast commands and you can refer to the below document for the same:

https://www.arista.com/en/um-eos/eos-section-40-5-pim-commands

As per the output of "show ip pim anycast-rp”command above , it should work fine.

Thanks,
Bhavana.

Post your Answer

You must be logged in to post an answer.