Posted on January 22, 2021 10:50 am
 |  Asked by Samim Nawabi
 |  135 views
RESOLVED
0
0
Print Friendly, PDF & Email

Hello All

I have a question regarding the Port-channel (LACP), on Arista DCS-7050TX3-48C8-R with EOS: 4.24.3.1. When I configure 2x different LACP port channels on same device, and connect them with Breakout Cable, the port-channel is not coming UP and give following logging info:

Lag: %LACP-4-ACTOR_CHURN: LACP Actor Churn Detected on Ethernet

But if it will be connected to other Switch it work just normal. Is it a Bug, or I need to change any configuration to support self connection with LACP?

Thanks!

0
Answered on January 22, 2021 10:51 am

Hi Samim,

Thanks for reaching out.

Please refer to the below TOI for LACP on Loopback interfaces:

https://eos.arista.com/eos-4-18-0f/lacp-on-loopback-interfaces/

a)As per the TOI,

LACP on Loopback Interfaces is disabled by default, and must be explicitly enabled on the loopback port-channel.

LACP on Loopback Interfaces can be enabled using:

Arista(config-if-Po1)#port-channel lacp loopback

b)Also as mentioned in the TOI, if we are configuring 1st scenario then that is not supported.(As far as I understand this is the one which is being configured in your network environment).

However 2nd scenario works fine.

 

Thanks,

Bhavana.

0
Posted by Samim Nawabi
Answered on January 22, 2021 12:49 pm

Thanks for info, but my question is not about to enable the Port-channel on loop back interface. My question is to connect 2x physical interfaces with 2x port-channels on the same Switch.

0
Posted by Naveen Chandra
Answered on January 25, 2021 3:48 am

Hi Samim,

I think, to understand your query better, it would be helpful to have your configuration and a topology diagram you want to achieve.

Could you please share the topology and the configuration you are implementing?

0
Posted by Sneha Rajeev
Answered on January 27, 2021 10:42 am

Hello Samim,

The below command shared by Bhavana should allow connecting two ethernet interfaces on the same device via a port-channel (and not loopback - LoX interfaces):

Arista(config-if-Po1)#port-channel lacp loopback

Please note that this configuration has to be entered in the port-channel configuration mode.

This command is supported since EOS-4.18.0F. However, in case you are running an older version of EOS on the device or if this issue is observed only with a break-out cable, you could configure static port-channels.

Thanks,

Sneha

 

Post your Answer

You must be logged in to post an answer.