Posted on February 10, 2021 9:52 pm
 |  Asked by Matthew Taylor
 |  183 views
RESOLVED
0
0
Print Friendly, PDF & Email

Hello I am getting the following output from a test veos image I am running in EVE-NG, I am running 4.24.1.1F veos code.  Almost there with setting this up any ideas I can follow up on?  Thanks!

category result detail
———————————- ——– ———————————-
MLAG Configuration Check FAIL
Peer VTEP IP FAIL Invalid local VTEP IP

MLAG sanity check has no issues, here is the VXLAN 1 show output

Vxlan1 is up, line protocol is up (connected)  —-VXLAN 1 appears up
Hardware is Vxlan
Source interface is Loopback1 and is active with 10.10.11.10
Replication/Flood Mode is headend with Flood List Source: EVPN
Remote MAC learning via EVPN
VNI mapping to VLANs
Static VLAN to VNI mapping is
[100, 10100]
Note: All Dynamic VLANs used by VCS are internal VLANs.
Use ‘show vxlan vni’ for details.
Static VRF to VNI mapping is not configured
MLAG Shared Router MAC is 0000.0000.0000

0
Answered on February 10, 2021 11:06 pm

Hi Matthew,

Thank you for writing to the forum. In the past cases, the error has been seen when two MLAG peers have different primary loopback IP for the VTEPs. Example:

(s1)#show run int lo1
interface Loopback1
description VXLAN Source
ip address 10.0.15.0/32 <<<<
ip address 10.0.15.255/32 secondary

(s2)#show run int lo1
interface Loopback1
description VXLAN Source
ip address 10.0.15.1/32 <<<<
ip address 10.0.15.255/32 secondary

Could you please verify if that is the case here?

Thank you,

0
Posted by Matthew Taylor
Answered on February 11, 2021 2:19 am

Correct lo1 have separate IP addresses, so they need to be the same?

SW1Loopback1 is up, line protocol is up (connected)
Hardware is Loopback
Description: Logical VTEP
Internet address is 10.10.11.10/32
Broadcast address is 255.255.255.255
IP MTU 65535 bytes (default)
Up 24 minutes, 19 seconds

SW2Loopback1 is up, line protocol is up (connected)
Hardware is Loopback
Description: Logical VTEP
Internet address is 10.10.11.11/32
Broadcast address is 255.255.255.255
IP MTU 65535 bytes (default)
Up 24 minutes, 25 seconds

3
Posted by Aniket Bhowmick
Answered on February 11, 2021 3:21 am

Hi Matthew

Yes, the primary Loopback IP addresses needs to be same on a MLAG pair. In fact the complete Vxlan configuration should be same on both switch in MLAG.

MLAG is used to group two L2 switches as logically one. With Vxlan being a L2 Tunnel (where we extend the Vlan), it is recommended to configure the exact same configurations on both switches in MLAG. This ensures, redundancy and avoid duplication of traffic.

For more information please go through the below articles:

https://eos.arista.com/vxlan-routing-with-mlag/

https://eos.arista.com/vxlan-with-mlag-configuration-guide/

Regards,

Aniket

Post your Answer

You must be logged in to post an answer.