Posted on December 30, 2014 9:59 am
 |  Asked by Don Clemons
 |  6531 views
Tags:
RESOLVED
0
0
Print Friendly, PDF & Email

I am running vEOS (4.14.5F) in a Lab environment and have set up a simple config of two switches connected via a single virtual hypervisor interface as an MLAG peer link. Each switch has 3 VLAN interfaces and I have configured VARP on them which works fine (show ip virtual-router displays all VARP links). When I place the VLAN interfaces into a VRF and add the ip address and ip virtual-router address back to the interface, VARP no longer works (show ip virtual-router displays an empty list). Below is a copy of the simple config for each switch I am using. If I take the VLAN interfaces out of the VRF, VARP will start working fine. Is this a bug, or is VARP not supported for VRF interfaces?

============================================
 hostname LeafP1A
 !
 spanning-tree mode mstp
 no spanning-tree vlan 4094
 vlan 2-4
 !
 vlan 4094
 trunk group m1peer
 !
 vrf definition UNDERLAY
 rd 100:100
 !
 interface Port-Channel10
 switchport mode trunk
 switchport trunk group m1peer
 !
 interface Ethernet1
 shutdown
 !
 interface Ethernet2
 shutdown
 !
 interface Ethernet3
 shutdown
 !
 interface Ethernet4
 shutdown
 !
 interface Ethernet5
 switchport mode trunk
 channel-group 10 mode active
 !
 interface Vlan1
 vrf forwarding UNDERLAY
 ip address 10.1.1.11/24
 ip virtual-router address 10.1.1.1
 !
 interface Vlan2
 vrf forwarding UNDERLAY
 ip address 10.1.2.11/24
 ip virtual-router address 10.1.2.1
 !
 interface Vlan3
 vrf forwarding UNDERLAY
 ip address 10.1.3.11/24
 ip virtual-router address 10.1.3.1
 !
 interface Vlan4094
 no autostate
 ip address 10.1.0.1/24
 !
 ip virtual-router mac-address 00:1c:73:00:09:99
 !
 no ip routing
 ip routing vrf UNDERLAY
 !
 mlag configuration
 domain-id mlagPod1
 heartbeat-interval 2500
 local-interface Vlan4094
 peer-address 10.1.0.2
 peer-link Port-Channel10
 reload-delay 150
 !
 end
=======================================
 hostname LeafP2A
 !
 spanning-tree mode mstp
 no spanning-tree vlan 4094
 vlan 2-4
 !
 vlan 4094
 trunk group m1peer
 !
 vrf definition UNDERLAY
 rd 100:100
 !
 interface Port-Channel10
 switchport mode trunk
 switchport trunk group m2peer
!
 interface Ethernet1
 shutdown
 !
 interface Ethernet2
 shutdown
 !
 interface Ethernet3
 shutdown
 !
 interface Ethernet4
 shutdown
 !
 interface Ethernet5
 switchport mode trunk
 channel-group 10 mode active
 !
 interface Vlan1
 vrf forwarding UNDERLAY
 ip address 10.1.1.12/24
 ip virtual-router address 10.1.1.1
 !
 interface Vlan2
 vrf forwarding UNDERLAY
 ip address 10.1.2.12/24
 ip virtual-router address 10.1.2.1
 !
 interface Vlan3
 vrf forwarding UNDERLAY
 ip address 10.1.3.12/24
 ip virtual-router address 10.1.3.1
 !
 interface Vlan4094
 no autostate
 ip address 10.1.0.2/24
 !
 ip virtual-router mac-address 00:1c:73:00:09:99
 !
 no ip routing
 ip routing vrf UNDERLAY
 !
 mlag configuration
 domain-id mlagPod1
 heartbeat-interval 2500
 local-interface Vlan4094
 peer-address 10.1.0.1
 peer-link Port-Channel10
 reload-delay 150
 !
 end
0
Posted by ma
Answered on January 5, 2015 2:33 pm

Hi Don,

VARP within a VRF is supported in vEOS starting from 4.14.1. Did you add the keyword “vrf” behind the ”show ip virtual router” command? I did a quick test and it works for me, see output below.

vrf definition NINE_NINE
rd 1:100
!
interface Vlan99
vrf forwarding NINE_NINE
ip address 99.99.99.1/24
ip virtual-router address 99.99.99.254
!
ip virtual-router mac-address aa:aa:aa:aa:aa:aa
veos-dc1-pod1-spine1(config-if-Vl99)# show ip virtual-router vrf NINE_NINE 
IP virtual router is configured with MAC address: aaaa.aaaa.aaaa
MAC address advertisement interval: 30 seconds
Protocol: U – Up, D – Down, T – Testing, UN – Unknown
NP – Not Present, LLD – Lower Layer Down

Interface       Vrf             IP Address          Virtual IP Address       Status       Protocol
————— ————— ——————- ———————— ———— ——–
Vlan99          NINE_NINE       99.99.99.1/24       99.99.99.254             down         LLD
veos-dc1-pod1-spine1(config-if-Vl99)# show version
Arista vEOS
Hardware version:
Serial number:
System MAC address:  0011.2233.4455

Software image version: 4.14.2F-2044273.4142F.1 (engineering build)
Architecture:           i386
Internal build version: 4.14.2F-2044273.4142F.1
Internal build ID:      ff008af3-52d5-4a7f-9025-8441151cd72a

Uptime:                 13 minutes
Total memory:           1474828 kB
Free memory:            28816 kB

Thanks,
-Michael

0
Posted by Don Clemons
Answered on January 5, 2015 5:33 pm

Mike,

Thanks for the response. You are correct that I was not prefixing the command with the appropriate VRF reference. It shows to be working correctly now. Thanks for the help.

- Don

0
Posted by Joakim Jansson
Answered on August 15, 2016 4:21 pm

Hello, i had the same problems as you. could not get it to work and the virtual-router gave the status ”stopped”

 

switch1(vrf:prod)(config)#sh ip virtual-router vrf prod
IP virtual router is configured with MAC address: 001c.7300.0099
IP router is not configured with Mlag peer MAC address
MAC address advertisement interval: 30 seconds

Protocol: U – Up, D – Down, T – Testing, UN – Unknown
NP – Not Present, LLD – Lower Layer Down

Interface Vrf Virtual IP Address Protocol State
————— ———- ———————— ————– ——-
Vlan2010 prod 172.26.156.1/22 U stopped

 

The fix was i had only enabled ip routing for my vrf and not the default vrf, im guessing it has something to do with my mlag between these two switches are in the default vrf..

Correct .

(kaveh khosravi at October 28, 2018 3:20 pm)

Post your Answer

You must be logged in to post an answer.