Posted on August 10, 2014 5:55 pm
 |  Asked by Joseph Callen
 |  5153 views
RESOLVED
0
0
Print Friendly, PDF & Email

Hello,

Is there anyway that you could provide an example configuration for the vEOS and VxLAN?

! Command: show running-config
! device: switch (vEOS, EOS-4.13.7M)
!
! boot system flash:/vEOS.swi
!
cvx
service vxlan
!
transceiver qsfp default-mode 4x10G
!
hostname switch
!
spanning-tree mode mstp
!
no aaa root
!
!
interface Ethernet1
no switchport
!
interface Ethernet2
shutdown
!
interface Ethernet3
shutdown
!
interface Loopback15
ip address 10.53.253.254/24
!
interface Management1
ip address 10.53.252.200/24
!
interface Vxlan1
vxlan source-interface Loopback15
vxlan udp-port 4789
!
ip route 0.0.0.0/0 10.53.252.1
!
ip routing
!
!
end

The et1 interface is attached to a ESXi distributed port-group (VLAN253 – 10.53.253.0/24).  I haven’t been able to ping the vxlan ip address.  I have had tried multiple static routes without any luck.  One of the remote VTEPs will be 10.53.253.62.  Certainly not an expert in networking, I am from the systems side, just wanted to test configure Arista with OpenStack Neutron/ML2 before putting it into production.

Thanks,

Joe

0
Posted by Alex
Answered on August 12, 2014 5:17 pm

Hi Joseph, can you provide some more detail on what exactly you are trying to achieve.  Do you want to map the VMs on VLAN 253 to a VXLAN VNI, with the VNI providing connectivity to the remote VTEP (10.53.253.62). Is the remote VTEP  another vEOS switch, also how is the remote VTEP connected to the vEOS switch; what ethernet interface and layer 3 configuration?

With the above scenario the VMs residing on VLAN 253 don’t need to and won’t be able to ping the VTEP IP address. The VTEP IP address is used as the source IP for VXLAN encapsulated frame, it doesn’t reside on the same subnet/layer 2 domain as the host VMs.

Thanks

Alex

 

 

Post your Answer

You must be logged in to post an answer.