Posted on February 11, 2015 9:58 pm
 |  Asked by Irek Romaniuk
 |  4212 views
0
0
Print Friendly, PDF & Email

I’ve setup two vEOS switches vEOS-1 and vEOS-2  on my ESXi 5.1 , connected e1 of both switches to port group PEER_LINK on the same vswitch. I can connect to mgmt interface but can’t ping between e1 interfaces, see below:

vEOS-1#ping 10.10.10.2
PING 10.10.10.2 (10.10.10.2) 72(100) bytes of data.
From 10.10.10.1 icmp_seq=1 Destination Host Unreachable

Configuration below. I tried e1 in both access and trunk mode, no difference. Please advise

 

vEOS-1#sh int statu
Port Name Status Vlan Duplex Speed Type
Et1 connected trunk full 10G EbraTestPhyP
Ma1 connected routed a-full a-1G 10/100/1000

vEOS-1#sh ip int br | ex un
Interface IP Address Status Protocol MTU
Management1 10.95.2.111/24 up up 1500
Vlan10 10.10.10.1/24 up up 1500

vEOS-2#sh int statu
Port Name Status Vlan Duplex Speed Type
Et1 connected trunk full 10G EbraTestPhyP
Ma1 connected routed a-full a-1G 10/100/1000

vEOS-2#sh ip int br | ex un
Interface IP Address Status Protocol MTU
Management1 10.95.2.112/24 up up 1500
Vlan10 10.10.10.2/24 up up 1500

Marked as spam
0
Posted by coreyhines
Answered on February 11, 2015 10:08 pm

Can you post your config? It looks like your vEOS instance does not actually recognize that it has an et1 interface. Please also post your ESXi configuration for the VM, specifically what virtual NIC driver are you using and do you have the port group configured with Promisq mode etc.

0
Posted by Irek Romaniuk
Answered on February 11, 2015 10:55 pm

See attached config and print screens , appreciate your help

Attachments:
0
Posted by Irek Romaniuk
Answered on February 12, 2015 12:07 pm

Appreciate , see attached

Attachments:
0
Posted by Brandon
Answered on February 17, 2015 1:30 am

How do you have the security settings configured on your virtual switch connecting the two vEOS instances together?

Specifically, the ”Promiscuous mode:”, ”MAC address changes:”, and ”Forged transmits:” for the vSwitch?

When I am working with a lab/test environment with vEOS, I typically set all of these settings to ”Accept”. When a packet is sent from a routed interface of vEOS, the MAC address used is that of the vNIC in ESXi… but when the packet is from a SVI/Vlan interface, the MAC address is that of the switch itself, and thus appears from the ESXi/vSwitch perspective to be a forged MAC address since it is not the MAC address of the vNIC.

0
Posted by Pranay B Mishra
Answered on February 24, 2015 11:57 pm

I see ip routing disabled on vEOS-2 (no ip routing). Can you enable it and see if it works?

0
Posted by Irek Romaniuk
Answered on February 25, 2015 12:48 pm

Right , I check all 3 ”Promiscuous mode:”, ”MAC address changes:”, and ”Forged transmits:” for the vSwitch..see attached above

0
Posted by Irek Romaniuk
Answered on February 26, 2015 1:06 pm

config posted twice above, showing port group in  Promiscuous mode and E1000 NIC driver

0
Posted by 高志 森須
Answered on April 7, 2016 6:46 am

Check the status of the spanning tree

Post your Answer

You must be logged in to post an answer.