Posted on March 30, 2018 1:52 pm
 |  Asked by Ning Zhang
 |  2716 views
RESOLVED
0
0
Print Friendly, PDF & Email

Hi, I run couples of latest vEOS switches on ESXi, trying to build a VXLAN lab to test.

Between vEOS switches, I used standard virtual switch as a virtual cable for each individual connection. 

In vSwitch settings, I’ve set the MTU to 9000.

MTU1500 works OK. But ping test over 1500 bytes all failed.

PING 172.16.11.0 (172.16.11.0) 1473(1501) bytes of data.

ping: sendmsg: Network is unreachable

ping: sendmsg: Network is unreachable

ping: sendmsg: Network is unreachable

Searching over Internet came up no result….

Any thought?

 

0
Answered on April 4, 2018 8:13 pm

Hi Ning,

What’s the MTU setting on the L3 routed port(s) facing the other vEOS VTEP? You’ll need account for the MTU overhead (50 Bytes) introduced by VxLAN in the underlay. For example, to support MTU of 9000 in your Overlay, you’ll need to set MTU to 9050 on your L3 Underlay links. Maximum value of MTU on Ethernet interfaces is 9214. Note that VxLAN encapsulated packets have DF bit set to avoid fragmentation in the underlay. Here’s an example to set max. MTU:

interface Ethernet1
   description L3 link towards spine
   mtu 9214
   no switchport
   ip address 50.0.0.1/30

Cheers
Naveen

0
Posted by Tim Evans
Answered on May 7, 2018 4:29 pm

I have encountered the same issue (vEOS-lab-4.20.1F on VMware ESXi 6.5U1), all MTUs (L2 and L3) are set appropriately to at least 9000 bytes but anything over 1500 bytes with DF bit set is lost.

While investigating this I noticed that when you drop into the bash shell the ifconfig command shows 1500 byte MTU for the interfaces associated with the front panel ports, regardless of what is set in the switch configuration. Manually changing the MTU for these interfaces from the bash shell using the ifconfig command solves the problem but I have not found any way of making these setting persist across reboots. I’m currently having to re-enter the ifconfig MTU change command every time I boot the switch.

Just in case someone needs to know how to do this, in my ESX environment I had to login to each switch and execute the following:

switch# bash

[admin@switch ~]$ sudo ifconfig vmnicet1 mtu 9000

In the above command, swap out ’vmnicet1’ with whichever interface you need at 9k MTU, then exit the bash shell and test!

(Joshua Hutchins at May 28, 2018 11:32 pm)
0
Answered on May 25, 2018 12:46 am

This is due to a known software bug on 4.20.x code. The fix will be coming in the upcoming releases. You can get in touch with Arista TAC if you’d like to know the specifics.

Post your Answer

You must be logged in to post an answer.