Posted on April 4, 2017 4:59 pm
 |  Asked by Bharath Ravindranath
 |  310 views
RESOLVED
0
0
Print Friendly, PDF & Email

Hi,

I am trying to use vEOS on GENI experimental portal as it seems ideal for my requirements. To do this I need to create a GENI image as given by http://www.exogeni.net/2014/07/creating-a-custom-exogeni-image-using-virtual-box/

So I tried to use vEOS 4.16.9M with Aboot 2.1.  But according to the GENI guide mentioned above, I need to create and save the OS image locally (in the guest VM). I am unable to mount an extra disk drive to my virtualbox (or use the pendrive). If you could help me with this, I would appreciate it greatly.

Also, I tried to use the .swi file and installer.iso as given in https://github.com/aristanetworks/eos_boot_loader
Here, I am facing a different problem. I can connect my net device of the guest to host OS before the autointi boot. But once I have booted the OS, I see that there is a persistent error (zerotouch configuration not found) and I am unable to configure my network to work properly (I am using bridged network connected to one of my host interfaces)

Thanks,
Bharath

0
Posted by Alexis Dacquay
Answered on April 22, 2017 7:25 pm

Hi Bharath,

I am not clear what you are asking with regards to the VortualBox problem you describe, around not being able to have an extra drive or pendrive USB stick. Could you clarify how you would like assistance?

For information, in the vEOS-lab instances available in the download section of arista.com you will some images with the mention “combined”, which mean that the Aboot is already included in the vEOS-lab image, so that there is no need to add a CD-drive to boot upon.

Regarding ZTP (ZeroTouch), if you don’t want to automate the provisioning, then you would have had visible instructions in the CLI explaining how to cancel or deactivate it, for example “zerotouch cancel”. Until it’s done the configs would not be saved as the switch is still in auto-provisioning mode.

More information about ZTP:

https://eos.arista.com/ztp-set-up-guide/

 

How to disable ZeroTouch:

https://ztpserver.readthedocs.io/en/master/tips.html#how-do-i-disable-enable-ztp-mode-on-a-switch

extract:

zerotouch cancel

 

 

Regards, 

Post your Answer

You must be logged in to post an answer.