Posted on February 7, 2019 7:05 am
 |  Asked by Neal Secher
 |  479 views
0
0
Print Friendly, PDF & Email

I’m trying to boot up a vEOS switch in VirtualBox via Vagrant. I’ve tried both new and old vEOS versions, but I hang here:

==> eos: Waiting for machine to boot. This may take a few minutes…
eos: SSH address: 127.0.0.1:12201
eos: SSH username: root
eos: SSH auth method: private key

nxosv boxes also fail, cumulus and Ubuntu boxes come up fine.

Any thoughts?

macOS: Mojave 10.14.3
Vagrant: 2.2.4
VirtualBox: 6.0.4
vEOS: 4.21.1.1F

0
Posted by edmund
Answered on February 10, 2019 3:40 am

Hi Neal,

I don’t see a problem booting 4.21.1F, but there is a long pause at the same stage you see vagrant hanging while the vm boots.

Have you tried adding this to your VagrantFile to monitor the console of the vm during bootup? That might help show where things break.

config.vm.provider “virtualbox” do |v|
v.gui = true
end

Sorry to just give you a “works for me”


==> eos: Booting VM...
==> eos: Waiting for machine to boot. This may take a few minutes...
eos: SSH address: 127.0.0.1:12201
eos: SSH username: root
eos: SSH auth method: private key
eos: Warning: Remote connection disconnect. Retrying...
eos: Warning: Connection reset. Retrying...
eos:
eos: Vagrant insecure key detected. Vagrant will automatically replace
eos: this with a newly generated keypair for better security.
eos:
eos: Inserting generated public key within guest...
eos: Removing insecure key from the guest if it's present...
eos: Key inserted! Disconnecting and reconnecting using new SSH key...
==> eos: Machine booted and ready!
==> eos: Checking for guest additions in VM...
eos: No guest additions were detected on the base box for this VM! Guest
eos: additions are required for forwarded ports, shared folders, host only
eos: networking, and more. If SSH fails on this machine, please install
eos: the guest additions and repackage the box to continue.
eos:
eos: This is not an error message; everything may continue to work properly,
eos: in which case you may ignore this message.

$ vagrant ssh eos

Arista Networks EOS shell

-bash-4.3# FastCli
localhost>sho ver
Arista vEOS
Hardware version:
Serial number:
System MAC address: 0800.2736.90c4

Software image version: 4.21.1.1F
Architecture: i386
Internal build version: 4.21.1.1F-10146868.42111F
Internal build ID: ed3973a9-79db-4acc-b9ac-19b9622d23e2

Uptime: 0 weeks, 0 days, 0 hours and 2 minutes
Total memory: 2016612 kB
Free memory: 1379324 kB

0
Posted by edmund
Answered on February 11, 2019 6:29 pm

Hi Neal,

This stopped working for me after upgrading VirtualBox to the same version as you have.
I found using an old version of Aboot resolves this but the version on arista.com (8.0.0) still hangs.

config.vm.provider :virtualbox do |vb|
vb.customize [“storageattach”, :id, “–storagectl”, “IDE”, “–port”, “0”, “–device”, “1”, “–type”, “dvddrive”, “–medium”, “/Users/edmund/Documents/Arista/Aboot-veos-2.0.10.iso”]
end

0
Posted by Sergej Pioch
Answered on May 24, 2019 1:23 pm

Hi, all!

I have problems using vagrant on virtualbox, too. When booting more than a single vEOS-lab instance, there is an Error:

Stderr: VBoxManage.exe: error: NamedPipe#0 failed to create named pipe \.pipevEOS-build-serial (VERR_PIPE_BUSY)
VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component ConsoleWrap, interface IConsole

I tried virtualbox images from vEOS-lab-4.20.10M as well as vEOS-lab-4.21.1.1F. virtualbox version is 5.2.30 r130521 (Qt5.6.2), Vagrant version 2.2.4. Both installed on a Windows 10 system.

Anyone similar issues? Any cheats to resolve?

That usually happens if you use multiple vagrant files. It’s recommended to define all your VMs within one Vagrantfile and deploy it like that. There’s a good example on the following github page: https://github.com/michaelc0n/vagrant-veos/blob/master/Vagrantfile (credit to Michael Saenz)
Hope this helps,
Tamas

(Tamas Plugor at May 24, 2019 7:50 pm)

Thanks, Tamas, for your answer. Unfortunately, this is not the case. Definition of virtual machines is located in a single Vagrantfile and even using the examle out of git (I tried the example with bowtieing four vEOS Switches together) I get the similar error.

Hm. Some more suggestions?

(Sergej Pioch at May 27, 2019 6:44 am)

I’ve found the issue! vagrant was automatically trying to use the same serial port for all VMs, which is not possible, hence it was complaining that \.pipevEOS-build-serial is busy (VERR_PIPE_BUSY), because it was already locked by the first VM that was brought up. You can also check the same if you go to VirtualBox, click on the VM, select settings, go to Serial Ports and you’ll see that both VMs will have the same path address ,which is wrong..
The solution is to either manually configure separate COM ports or disconnect the serial port in the Vagrantfile. I chose to disconnect it
e.g. for my spine01 VM I’ve added this:

spine01.vm.provider “virtualbox” do |v|
v.customize [“modifyvm”, :id, “–uartmode1”, “disconnected”]
end

With that I was able to bring up multiple VMs.

FYI I had issues with the net-ssh module, so after bringing up each VM, I had to use ‘vagrant up’ once or twice for the next one to start

Hope this helps,
Tamas

(Tamas Plugor at May 28, 2019 7:07 pm)

Post your Answer

You must be logged in to post an answer.