Posted on March 30, 2018 1:47 pm
 |  Asked by Victor Rodrigues
 |  1963 views
RESOLVED
0
0
Print Friendly, PDF & Email

Hello,

I’m running Arista vEOS 4.18.1F, and a configured vlan for either trunk and access mode interfaces and I’m not able to see the vlan counters:

localhost(config)#show vlan counters

Hardware VLAN Counters: Disabled

 

 localhost(config)#show vlan

VLAN  Name                             Status    Ports

—– ——————————– ——— ——————————-

1     default                          active    Et1, Et2, Et3, Et4, Et7, Et10Et11, Et12

20    Federation                       active    Et5, Et6, Et8, Et9 

 

 

Is there some configuration needed to check vlan counters, or is a version problem?

Appreciate any help!

0
Answered on April 4, 2018 8:37 pm

Hi Victor,

This is a platform specific feature and not supported on vEOS. It’s supported on 7280 and 7500 series switches. You’ll need the following commands to enable the feature on these platforms:

hardware counter feature vlan in
hardware counter feature vlan out

Hope this helps.

Cheers
Naveen

0
Posted by Peter Peter
Answered on April 17, 2018 1:10 am

These counters seem to be missing traffic in my testing. Particularly in the out direction.

0
Posted by Gert Döring
Answered on June 8, 2020 6:40 pm

Hi,

was this ever resolved?  I have a 7280R with 4.23.3M here, and I have nicely working *outbound* counters, but all inbound is 0...

 

m54#sh vlan counter
Vlan InOctets InPkts
Vlan1 0 0
Vlan131 0 0
Vlan132 0 0
Vlan133 0 0
Vlan134 0 0

Vlan OutOctets OutPkts
Vlan1 0 0
Vlan131 1990878944 15111984
Vlan132 50614064 559476
Vlan133 50606614 559376
Vlan134 1698329754 1042755

0
Posted by Tamas Plugor
Answered on June 9, 2020 12:13 am

Hi Gert,

Did you enable the feature as mentioned above?

(config)#hardware counter feature vlan in
#sh vlan counter

Vlan                 InOctets          InPkts
Vlan1                    2068              11
Vlan10                   1850              15
Vlan11                      0               0
Vlan12                      0               0
Vlan30                      0               0
Vlan31                      0               0
Vlan4093                  192               2
Vlan4094                    0               0

Post your Answer

You must be logged in to post an answer.