Posted on July 18, 2021 6:06 am
 |  Asked by Sean Griffin
 |  14 views
0
0
Print Friendly, PDF & Email

I am trying play around with vmtracer and I’m having an issue getting connected to vCenter from my arista 7124SX switch. It’s showing a “SSL Error”. Any help would be greatly appreciated!

SW0#sh ver
Arista DCS-7124SX-R
Hardware version: 01.05
Serial number: JPE12500225
System MAC address: 001c.7325.cdc4

Software image version: 4.13.16M
Architecture: i386
Internal build version: 4.13.16M-3213248.41316M.1
Internal build ID: 53e27db5-14d8-4d71-8ea1-a71aa337946f

Uptime: 4 days, 6 hours and 55 minutes
Total memory: 4025308 kB
Free memory: 1715076 kB

SW0#show vmtracer session vcenter vcenter detail
Session vcenter
vCenter URL https://10.10.0.242/sdk
username arista@vsphere.local
autovlan disabled
allowed-vlans 1-4094
sessionState Disconnected
lastStateChange 0:00:28 ago
lastMsgSent Retrieve service content message
timeOfLastMsg 0:00:28 ago
responseTimeForLastMsg 0.0
numSuccessfulMsg 0
lastSuccessfulMsg —
lastSuccessfulMsgTime never
numFailedMsg 4
lastFailedMsg Retrieve service content message
lastFailedMsgTime 0:00:28 ago
lastErrorCode RetrieveServiceContent SOAP 1.1 fault: SOAP-ENV:Client [no subcode]
“SSL error”
Detail: [no detail]

2021-07-18T01:01:38.933968-05:00 SW0.isaweirdo.com VmTracer: %VMWAREVI-3-CONNECT_FAILED: Failed to connect to vCenter. RetrieveServiceContent (message repeated 2 times in 89.9971 secs)

VMWare vCenter version 7.0

0
Answered on July 19, 2021 4:13 am

Hi Sean,

Thanks for reaching out.

VmTracer was not able to connect to the vCenter based on the below log and showing "SSL error" from the output:

2021-07-18T01:01:38.933968-05:00 SW0.isaweirdo.com VmTracer: %VMWAREVI-3-CONNECT_FAILED: Failed to connect to vCenter. RetrieveServiceContent (message repeated 2 times in 89.9971 secs)

 

Could you please provide us the VM Tracer configs and following outputs from the device to further investigate into the issue:

show tech-support | no

show logging system

show vmtracer all
show vmtracer interface
show vmtracer vm detail
show vmtracer vnic counters

 

Is there any firewall deployed in between the path and did we allow appropriate rules/port 443 on firewall ?Could you try  telnetting to port 443 of the vCenter and let us know if you are able to connect ?

 

Also 7124SX platform has reached End Of Life(EOL) long back and EOS version running (4.13.16M) is very old and has reached end of support before 4 years.We would suggest you to contact your Arista SE for further recommendation regarding platform models and latest EOS code for upgradation.

 

Please refer to the below EOS Life cycle policy:

https://www.arista.com/en/support/product-documentation/eos-life-cycle-policy

 

Thanks,

Bhavana.

Post your Answer

You must be logged in to post an answer.