Posted on September 8, 2015 10:58 am
 |  Asked by Anand Balakrishnan
 |  4480 views
Tags:
RESOLVED
0
0
Print Friendly, PDF & Email

Hi All,

I have a vEOS instance as well as a Arista hardware box. I was trying to configure vrf in both. In hardware box it was easy to configure and was able to ping my gateway using ping vrf <newvrf> <IP> command.

The same configuration i tried in vEOS but it is not pinging. Is there any special config to enable vrf in vEOS? Both are in same LAN and has common gateway. The gateway is lying in a Cisco device which is out of my access. From vEOS i can do self ping, but none other IPs in same segment is not reachable. I believe, in Cisco end the port which is connected to Arista hardware will be configured as access port and the port which is plugged to VM might be configured as trunk.

Can anyone figure out where the issue might be?

 

Thanks in advance,

Anand

0
Posted by Edmund
Answered on September 8, 2015 3:59 pm

 

Hello Anand,

Could you share your configuration, version and what hypervisor you’re using?

If this is for the management vrf and you’re using VMware one thing to try is

bash sudo ifconfig ma1 promisc

 

0
Posted by Anand Balakrishnan
Answered on September 8, 2015 6:45 pm

Hi Edmund,

Many thanks. It works!! :)

Btw, what is the purpose of this command? What it will do exactly?

Regards,

Anand

It will put the management interface into promiscuous mode so all packets received will be sent to the OS.
When you put the management interface into a VRF, the mac address changes, and this appears to cause some problems with ESX. With the promisc setting, we accept all packets regardless of the MAC address used.

ToR1#sho run int ma1
interface Management1
ip address 10.0.2.9/24
ToR1#sho interfaces ma1 | grep Ethernet
Hardware is Ethernet, address is 0800.2720.295f (bia 0800.2720.295f)
ToR1#conf t
ToR1(config)#int ma1
ToR1(config-if-Ma1)#vrf forwarding MGMT
! Interface Management1 IP address 10.0.2.9 removed due to enabling VRF MGMT
ToR1(config-if-Ma1)# ip address 10.0.2.9/24
ToR1(config-if-Ma1)#end
ToR1#sho interfaces ma1 | grep Ethernet
Hardware is Ethernet, address is 0800.27bd.b723
ToR1#

(Edmund at September 10, 2015 7:01 pm)
0
Posted by Rich Johnson
Answered on January 27, 2016 2:57 pm

Greetings All,

The command that Edmund posted works:
bash sudo ifconfig ma1 promisc

The following command also performs the same function:
sudo ip link set ma1 promisc on
Another issue is that neither command appears to be persistent (do not survive a reboot)

Here is a way that I’ve implemented ensuring the command is loaded at bootup:

Created a script named ma1-promisc-on.sh which contains the following:

==============================================================================
#!/bin/bash

sudo ip link set ma1 promisc on
==============================================================================

I then utilized Event-Handler to run the script on bootup (with a 15 second delay)

==============================================================================
event-handler ma1-promisc-on
trigger on-boot
action bash /mnt/flash/ma1-promisc-on.sh
delay 15
==============================================================================

Regards,

Rich

Post your Answer

You must be logged in to post an answer.