Posted on January 27, 2017 2:24 pm
 |  Asked by Tiago Sousa
 |  2235 views
Tags:
0
0
Print Friendly, PDF & Email

Is it possible to obtain each VRF routing table via SNMP on Arista?  mplsL3VpnVrfRteInetCidrDest does not exist(?). thank you

0
Posted by Michael Sparacio
Answered on January 27, 2017 2:28 pm

yes, this is possible.

for IP routes MIB2 IP-FORWARD-MIB RFC4292 ipForwardTable:
$ snmpwalk -c public@vrf1 -v 2c 172.28.170.42 .1.3.6.1.2.1.4.24

generic example:
snmpwalk -c community@vrfname -v 2c mgmt-ip-addr asn.1

for arp/mac entries MIB2 IP-MIB RFC2011 ipNetToMediaTable:
$ snmpwalk -c public@vrf1 -v 2c 172.28.170.42 .1.3.6.1.2.1.4.22

0
Posted by Tiago Sousa
Answered on January 27, 2017 2:56 pm

Did you configure something else on the device? I tried with 

snmpwalk -c community@vrfname -v 2c mgmt-ip-addr and get:

Timeout: No Response from device

with:

snmpwalk -c community -v 2c mgmt-ip-addr it works (just for the global routing table)

0
Posted by Michael Sparacio
Answered on January 30, 2017 1:20 pm

are your vrf’s properly defined?

in the following, vrf-1 and vrf-2 are properly defined. vrf-3 is missing the RD. I can query vrf-1 and vrf-2. vrf-3 will timeout.

(config)#sh run sec vrf
vrf definition vrf-1
rd 65000:1
!
vrf definition vrf-2
rd 65000:2
!
vrf definition vrf-3
!
interface Ethernet1
no switchport
vrf forwarding vrf-1
ip address 1.0.0.78/24
!
interface Ethernet2
no switchport
vrf forwarding vrf-2
ip address 2.0.0.78/24
!
interface Ethernet3
no switchport
vrf forwarding vrf-3
ip address 3.0.0.78/24
!
ip routing vrf vrf-1
ip routing vrf vrf-2
ip routing vrf vrf-3
!
(config)#show vrf
Maximum number of vrfs allowed: 14
Vrf RD Protocols State Interfaces
———– ————— ————— ——————– ———-
vrf-1 65000:1 ipv4,ipv6 v4:routing, Ethernet1
v6:no routing

vrf-2 65000:2 ipv4,ipv6 v4:routing, Ethernet2
v6:no routing

vrf-3 v4:incomplete,
v6:incomplete

$ snmpwalk -c public@vrf-2 -v 2c 192.168.1.78 .1.3.6.1.2.1.4.24
IP-MIB::ip.24.3.0 = Gauge32: 16
IP-MIB::ip.24.4.1.1.1.1.1.0.255.255.255.0.0.2.0.0.77 = IpAddress: 1.1.1.0
IP-MIB::ip.24.4.1.1.1.1.2.0.255.255.255.0.0.2.0.0.77 = IpAddress: 1.1.2.0
IP-MIB::ip.24.4.1.1.1.1.3.0.255.255.255.0.0.2.0.0.77 = IpAddress: 1.1.3.0
IP-MIB::ip.24.4.1.1.1.1.4.0.255.255.255.0.0.2.0.0.77 = IpAddress: 1.1.4.0
IP-MIB::ip.24.4.1.1.1.1.5.0.255.255.255.0.0.2.0.0.77 = IpAddress: 1.1.5.0
…(output omitted)

$ snmpwalk -c public@vrf-3 -v 2c 192.168.1.78 .1.3.6.1.2.1.4.24
Timeout: No Response from 192.168.1.78

Post your Answer

You must be logged in to post an answer.