• ルータ間リンクのIPアドレス

 
 
Print Friendly, PDF & Email

はじめに

ホストが存在しないルータ間リンク(ルータ同士を接続する間のリンク)でのIPアドレスは過去より色んな議論があった。

ネットワーク/ブロードキャストと2台のホストだけが存在する30ビット(例:10.1.1.0/30)の使用

これらを改善した31ビット(例:10.1.1.0/31) の利用 RFC3021 31-Bit Prefixes on IPv4 Links

IPv4だけではなく、IPv6でも127ビットを使用するRFC6164 Using 127-Bit IPv6 Prefixes on Inter-Router Linksも存在。

本ブログではルータ間リンクにフォーカスして記事を作成する。

 

リンクローカルアドレス

直接ルータ間リンクでの利用のみを指すものではないが、IPv6では設計当初より外部とは直接やり取りをしないリンクローカルアドレスが存在し、IGPプロトコルではこのアドレスを用いて隣接関係を確立をする。

これらの特徴とMPBGPを使ってIPv6リンクローカルアドレスでBGPを確立し、IPv6BGPリンク上でIPv4のプレフィックスを広告する RFC5549 を用いてデータセンターを構築する例も増えてきている。

AS Ranges for Dynamic BGP Peer Groups

IPv4では設計当初にはリンクローカルというアドレスは存在していなかったが、RFC3927 で169.254/16が割り当てられ、大手クラウドプラウドプロバイダーのBGP接続用のアドレスなどでも使用されている。

IP Unnumberedアドレス

ポイントツーポイントのネットワークでは従来PPP(Point to Point Protocol)というプロトコルが使われきた。

IP Unnumberedという手法はリンク間のアドレスを設定するのではなく、ループバックなどのアドレスを借りてきてそのアドレスを識別子として用いてポイントツーポイントを確立する。

RFC5309 Point-to-Point Operation over LAN in Link State Routing Protocolsではこれと同じ手法(loopbackアドレスを識別子として使用)を用いてリンクローカルプロトコルの隣接関係を確立する手法を定めている。

アリスタEOSでも4.23.0.Fより実装をしている。

IPv4 Unnumbered Interfaces

 

R1#show startup-config | section ospf
interface Ethernet1
no switchport
ip address unnumbered Loopback0
ip ospf network point-to-point
ip ospf area 0.0.0.0
!
interface Ethernet2
no switchport
ip address unnumbered Loopback0
ip ospf network point-to-point
ip ospf area 0.0.0.0
!
router ospf 1
passive-interface Ethernet3
network 10.100.1.0/24 area 0.0.0.0
network 10.255.255.1/32 area 0.0.0.0
max-lsa 12000

上記の様にインターフェースにてUnnumberedの設定と参照とするインターフェースを指定とポイントツーポイントの設定とAeaなどの設定を行う。

まとめ

ルータ間リンクで使うアドレス(/31,/127,リンクローカル,unnumbered)について簡単にまとめてみた。

実際にルータ間リンクの設計の見直しで大量にグローバルIPv4アドレスを確保出来た例もあり、参考頂ければと思う。

 

Follow

Get every new post on this blog delivered to your Inbox.

Join other followers: