• Arista Any Cloud Platform – AWSでのvEOS Routerデプロイガイド

 
 
Print Friendly, PDF & Email

はじめに

本文書は、Arista vEOSルータをAmazon Web Service (AWS)へデプロイする方法を紹介します。このドキュメントのセクションは実行順序に基づいて構成されており、vEOSルータのデプロイにはこの順序に沿って行ってください。

概要

Aristaは、プライベートクラウドとパブリッククラウドの両方で、ワークロードを配置するための魅力的なオプションとなる大幅な効率性を提供します。プライベートクラウドでは、業界標準のプロトコルを利用し、シンプルでスケーラブルなSpine / Leafトポロジで、実証しています。Any Cloudは、実績のある2つのソフトウェアプラットフォーム、EOSとCloudVisionを拡張し、一貫したマルチクラウドのアーキテクチャと運用のアプローチを提供しています。

vEOSルータをAWSに導入すると、vEOSは拡張されたネットワーキング機能を利用して、EC2仮想マシンのスループット向上と遅延時間の短いネットワークを実現します。 これは、最大25 Gbpsの速度を提供できるElastic Network Adapter(ENA)ドライバを介して行われ、vEOSルータのすべての推奨されるAWSインスタンスタイプでサポートされています。

 

前提条件

Arista vEOS ルータをAWSにプロビジョニングするには、以下の前提条件を満たす必要があります。

  • AWSアカウントを取得します。

  • デプロイメントの規模、すなわち必要なインスタンスのタイプを決定します。 この文書では、vEOSルータはC4.xlargeインスタンスとしています。

  • AWS MarketplaceでArista vEOS ルータを検索してください。

  • WindowsのPuttyなどのSSHクライアント。Mac OSXとLinuxでは、SSHクライアントはネイティブで提供されています。

トポロジ

下図の赤枠で示したVPC-1、関連コンポーネント、vEOSルータ(vRouter-1)、Linuxホスト(Host-1)インスタンスをデプロイします。この文書では、VPC-2とTransit-VPCがすでに定義済みであると想定します。

この論理レイアウトでは、vEOSルータはサブネットルータとLinuxインスタンスの間に存在します。 実際のAWS VPC内のネットワークの仕組みでは、vEOSルータとlinuxインスタンスの両方がサブネットルータに並行して接続します。 したがって、vEOSルータを経由する接続では、サブネットルータに宛先ネットワーク用のルートを追加する必要があります。

デプロイの手順

まずは、トポロジのセクションに示されているVPC-1を構築するために必要な全体のステップを示します。 デプロイするためには、すべての手順を実行する必要があります。

 

  • VPCを作成

  • VPC内にサブネットを作成

  • VPC用のインターネットゲートウェイを作成

  • VPCピアリングを作成

  • セキュリティグループを更新

  • キーペアを作成

  • vEOSルータインスタンスのネットワークインタフェースを作成

  • AWSコンソールから、vEOSルータインスタンスをインスタンス化

    • 定義済みのvEOS ルータインターフェイスを割り当て

    • インスタンスのプロビジョニングのUser Dataセクションで、事前定義のvEOSコンフィグを適用

  • サブネットルーティングテーブルを更新

これらのコンポーネントをすべてデプロイしたら、vRouter-1(パブリックに割り当てられたIP)に接続します。 その後、vRouter-1インスタンスを介してHost-1インスタンスに接続します。 すべてが正しく構築されていることを確認するには、Host-1(10.1.11.10)からTransit-Host(10.100.11.10)へのpingを行います。

AWS ログイン

AWSへ最初にログインすると、以下のようなAWSサービスダッシュボードが表示されます:

 

VPCと関連コンポーネント

VPCのIPv4アドレス範囲を指定する必要があります。 IPv4アドレス範囲をクラスレスドメイン間ルーティング(CIDR)ブロックとして指定します。 本文書のトポロジに基づいて、10.1.0.0/16を割り当てます。 /16より大きいIPv4 CIDRブロックを指定することはできません。 任意でAmazon提供のIPv6 CIDRブロックをVPCに関連付けることができます。

 

VPCの作成

Services」からドロップダウンメニュー(左上)をクリックし、「VPC」を選択して「VPC Dashboard」に移動します:



 

‘VPC Dashboard’ から ‘Your VPC’s’を選択します:

 

‘Create VPC’ をクリックし、‘VPC-1’ という名前のVPCを作成し、IPv4 CIDRブロックとして10.1.0.0/16’を入力します:

VPC内のサブネット作成

CIDR形式を使用して、先ほど作成したVPC内の各サブネットのIPアドレスブロックを指定します。 ここで定義するサブネットは、デモトポロジごとのすべてのLinuxインスタンスネットワークを網羅する必要があります。 ネットマスクは、/16と/28の間にしてください。 また、サブネットはVPCと同じサイズにすることができます。 IPv6 CIDRブロックは/64 CIDRブロックでなければなりません。

 

VPC Dashboard」から「Subnets」を選択し、「Create Subnet」をクリックします。 ‘10.1.1.0/24 ‘などの適切な名前タグを割り当てて、作成したVPCを選択し、IPv4 CIDRブロックに’10.1.1.0/24’と入力します。 同じ手順でトポロジに基づいて’10.1.11.0/24 ‘の別のサブネットを作成します。


ルーティングテーブルの作成と更新

VPCを作成すると、ルーティングテーブルが作成され、各VPCに関連付けられます。 自動的に作成されたデフォルト(メイン)ルーティングテーブルの名前が更新されます。 

 

VPC Dashboard」の「Route Tables」をクリックし、検索ボックスに次のように作成したVPCの名前(VPC-1)を入力します。 ルーティングテーブルを選択し、下の図のように[Subnet Associations]をクリックします:

 

 

Edit‘をクリックし、’10.1.1.0/24 ‘サブネットを選択して[Save]をクリックします。

 

このルートテーブルの「Name」を更新して、関連付けられているサブネットと一致させます。

 ここでは、デモトポロジに基づいて’10.1.11.0/24 ‘サブネットのルーティングテーブルを作成します。 ‘Create Route Table‘をクリックし、名前タグとして’10.1.11.0/24 ‘と入力します:

 

‘10.1.11.0/24 ‘サブネットのルートテーブルが作成されると、そのサブネットアソシエーションが更新されます。 そのサブネットが選択されている間、 ‘Subnet Associations‘タブをクリックし、 ‘Edit‘をクリックし、’10.1.11.0/24 ‘サブネットを選択し、’Save‘をクリックします:

 

 

この文書では、10.1.1.0/24および10.1.11.0/24サブネットのルートテーブルを更新します。

VPC用インターネットゲートウェイの作成

インターネットゲートウェイは、VPCをインターネットに接続する仮想ルーターです。 インターネットゲートウェイを作成して有効にすると、接続されているVPC用のゲートウェイ経由でインターネットへのデフォルトルートが有効になります。

 

VPC Dashboard」から「Internet Gateways」を選択し、下の図のように「Create Internet Gateway」をクリックします。 VPC-1のインターネットゲートウェイを作成し、名前タグに「VPC-1-IGW」を割り当てます:

 

 

インターネットゲートウェイが作成されたら、VPC-1に接続します。 「VPC Dashboard」から「Internet Gateways」を選択し、VPCに接続するインターネットゲートウェイを選択し、下の図のように「Attach to VPC」をクリックします。 ドロップダウンメニューからそれぞれのVPCを選択し、「Yes, Attach」をクリックします:

 

インターネットゲートウェイを作成してVPC-1に接続した後、このインターネットゲートウェイを使用するための0.0.0.0/0のルートは、インターネットへのアクセスまたはインターネットからの到達可能性が必要なサブネットに追加する必要があります。 今回のトポロジーでは、Linuxインスタンスサブネット(10.1.11.0/24)がインターネットにアクセスできるようにします。 このサブネットのルーティングテーブル更新については文書の後半で紹介します。

VPC Peeringの作成

VPCピアリング接続は、2つのVPC間のネットワーク接続で、プライベートIPv4アドレスまたはIPv6アドレスを使用してトラフィックをルーティングできます。 このVPCピアリングは、このトポロジのVPC間のIP到達可能性、すなわち10.1.1.0/24 <> 10.100.1.0/24の間の接続性を目的としています。 これにより、Transit-vRouter(すでにプロビジョニングされている)とvRouter-1(このドキュメントの後半でインスタンス化されます)との間のGRE、BGP、およびIPSec接続が可能となります。 この手順では、プロビジョニングしているTransit VPCとEdge VPCの両方が同じアカウントにあることを前提としています。 :異なるアカウント間のVPCピアリングでは、信頼関係を確立する必要があります。

 

VPC Dashboard」から「Peering Connections」を選択し、次に「Create VPC Peering Connection」をクリックします。 このVPCピアリング接続の「名前タグ」として「VPC-1 <> Transit」を指定します。 Local VPC to Peerセクションに「VPC-1」と入力すると、VPC IDが自動的に入力されます。 「Select another VPC to peer with」のVPCセクションで、次のようにTransit-VPC IDを選択します:

 

VPCピアリング接続が作成されたら、それを選択し、「Actions」ドロップダウンメニューから「Accept Peering Connection Request」オプションを選択し、「Yes, Accept」をクリックします:

 

次の画面で[閉じる]をクリックします。 先ほど作成したVPCピアリング接続を指すように、10.1.1.0/24および10.100.1.0/24サブネットのルーティングテーブルを更新する必要があります。 これらのサブネットのルーティングテーブルは、この文書の後半で説明します。

Security Groupsの更新

既定のセキュリティグループは、VPCを作成したときに作成されました。 VPCの作成時にデフォルトで作成されたセキュリティグループの名前を更新し、インバウンドルールを更新します。

 

VPC Dashboard」から「Security Groups」セクションをクリックします。 [Create Security Group]をクリックして、作成したばかりのVPCの名前を検索ボックスに入力します 。 セキュリティグループの「名前タグ」を編集し、「VPC-1-Security_Group」と入力します:

 

[Inbound Rules]タブをクリックし、[Edit]をクリックして特定のポート/プロトコルの10.100.0.0/16および10.2.0.0/16(トポロジに基づく)を許可します:

EC2インスタンスと関連コンポーネント

vEOSルータインスタンス(vRouter-1)とLinuxインスタンス(Host-1)はEC2インスタンスとしてプロビジョニングされます。 次のセクションでは、vRouter-1インスタンスとlinux Host-1インスタンスのインスタンスを作成します。

 

Services」ドロップダウンメニュー(左上)をクリックし、次に「EC2」を選択すると、下の画像のように「EC2 Dashboard」に移動します:

vEOS Router AMI イメージの入手

vEOSルータは、以下のようにAmazonマーケットプレースから入手することができます。 vEOSルータはBYOLとして利用可能です。



キーペアの作成

Amazon EC2は、公開鍵暗号を使用してログイン情報を暗号化および復号化します。 公開鍵暗号は公開鍵を使用してパスワードなどのデータを暗号化し、受信者は秘密鍵を使用してデータを復号化します。 公開鍵と秘密鍵はキーペアと呼ばれます。

 

インスタンスにログインするには、キーペアを作成し、インスタンスを起動するときにキーペアの名前を指定し、インスタンスに接続するときに秘密鍵を指定する必要があります。 Linuxインスタンスにはパスワードはなく、SSHを使用してログインするにはキーペアを使用します。

 

EC2 Dashboard」で「Key Pairs」を選択し、「Create Key Pair」をクリックします。 今回のデプロイでは、「Arista-vEOS-Router’」という名前のキーペアを作成します。

 

Create」をクリックすると、キーペアが作成され、自動的に「Arista-vEOS-Router.pem」という名前のファイルがダウンロードされます。 ダウンロードしたら、ファイルの権限を変更する必要があります。

 

Permissions 0644 for ‘Arista-vEOS-Router.pem’ are too open.

It is required that your private key files are NOT accessible by others.

This private key will be ignored.

(「Arista-vEOS-Router.pem」のパーミッション0644だと、見えすぎです。

秘密鍵ファイルには他の人がアクセスできないようにする必要があります。

この秘密鍵は無視されます。)

 

次のコマンドを実行して、 ‘Arista-vEOS-Router.pem’ファイルのアクセス許可を変更します:

 

chmod 400 Arista-vEOS-Router.pem

 

作成するEC2インスタンスにアクセスするには2つの方法がありますが、ダウンロードしたばかりのPEMファイルを参照することもできますし、SSHコマンド(Arista-vEOS-Router.pemファイルがあるディレクトリから) ‘ssh -i Arista-vEOS-Router.pem ec2-user@<$IP_Address>’ を使用するか、このキーを認証エージェントに追加します。認証エージェントを使うと、SSHを使用してEC2インスタンスに接続するたびに参照する必要はありません:

 

host$ ssh-add Arista-vEOS-Router.pem

Identity added: Arista-vEOS-Router.pem (Arista-vEOS-Router.pem)

 

キーが認証エージェントに追加されると、EC2インスタンスは次のようにアクセスできます:

‘ssh -i ec2-user@<$IP_Address>’.

全EC2インスタンスのネットワークインタフェースの作成

EC2インスタンシエーションでは、3つ以上のインターフェイスの割り当てが制限されます。 vEOSルータのアウトオブバンド管理ポートはありません。イメージとインターフェイスの割り当てはEthernet1で始まります。 

 

EC2 Dashboard」で「Network Interfaces」を選択し、「Create Network Interface」をクリックします。 ‘Description‘に ‘vRouter-1-ETH1’を指定し、トポロジに基づいて’10.1.1.6 ‘を’Private IP’‘として割り当てます。 「default」のセキュリティグループを選択し、「Yes, Create」をクリックします。 

 

同じ手順で、 ‘vRouter-1-ETH2’の別のネットワークインターフェイスを作成し、トポロジに基づいて ‘10.1.11.6’を「Private IP」として割り当てます。

 

同じ手順で、 ‘Host-1’の別のネットワークインターフェイスを作成します。 そのネットワークインターフェイスの「Description」に「Host-1-ETH0」を使用し、トポロジに基づいて「10.1.11.6」を「Private IP」として割り当てます。

 

インターフェイスが作成されると、それらのインターフェイスを作成する際に指定したDescriptionに一致するように、「Name」が更新されます。 vrouter-1で検索すると、vrouter-1をDescriptionに入れて作成したインターフェイスだけが表示されます。

 

host-1を検索すると、host-1をDescriptionに入れて作成したインターフェースが表示されます。

 

次に、両方のvRouter Network Interfacesを個別に選択し、「Actions」をクリックし、「Change Source/Dest. Check」を無効にします。 チェック’。 [Source / Destination Check]属性は、インスタンスでソース/宛先チェックを有効にするかどうかを制御します。 この属性を無効にすると、インスタンスは、インスタンスに特化していないネットワークトラフィックを処理できます。 注:これはHost-1ネットワークインターフェイスには必要ありません。

 

このデプロイに必要なすべてのネットワークインターフェイスが作成されると、「EC2 Dashboard」の「Network Interfaces」セクションの表示は次のようになります:

vEOSルータインスタンスのインスタンス化

このセクションでは、vEOS Routerインスタンス(vRouter-1)の作成について説明します。

 

EC2 Dashboard」内から「Instances」をクリックしてから「Launch Instance」をクリックします。From within the ‘EC2 Dashboard’ click on ‘Instances’ and then ‘Launch Instance’.

 

Launch Instance‘は、インスタンスを作成する複数ステップのプロセスにリダイレクトする必要があります。 まず、インスタンス化しようとしているインスタンスのAMIイメージを選択する必要があります。

 

インスタンス化しようとしているインスタンスのAMIイメージを選択します。 左側の ‘AWS Marketplace‘タブをクリックし、 ‘arista networks’を検索して ‘Enter’を押します。 すると次のようにArista vEOS Router(BYOL)AMIイメージが出てきます。価格設定の詳細セクションで「Select」をクリックし、次に「Continue」をクリックしてステップ#2に進みます。

 

次のステップ「Choose Instance Type」で、インスタンス・タイプCompute Optimized / c4.xlargeを選択し、「Next: Configure Instance Details」をクリックします。 (:テスト目的でのみCompute Optimized / c4.xlargeを選択しています。vEOSルータは、価格設定セクションで指定された各種EC2インスタンスタイプで実行できます):


ステップ3で、 ‘Network’で ‘VPC-1’を、 ‘Subnet’で’10.1.1.0/24 ‘を割り当てていることを確認します:

スクロールダウンして、vEOSルータの事前定義されたvRouter-1-ETH1インターフェイスを選択します(AWSのETH0はvEOSのETH1にマップされます)。 次に、[Add Device]をクリックしてETH1インターフェイスを追加します。

ETH1が追加されると、vEOSルーターのあらかじめ定義されたvRouter-1-ETH2インターフェイスにマップします(AWSのETH1はvEOSのETH2にマップします)。

 

さらに下にスクロールし、[Advanced Details]セクションを展開します。 このテキストボックスにvRouter-1のConfigを貼り付けます(この文書の付録にあるvRouter-1とTransit-vRouterの設定)。 ‘%EOS-STARTUP-CONFIG-START%‘を先頭に、 ‘%EOS-STARTUP-CONFIG-END%‘を文末に含めてください。 これにより、インスタンシエーション中にEOS設定がそのインスタンスに ‘Startup-config’として適用されます。 [Next: Add Storage]をクリックします。

ステップ4で、[Next: Add Tags]をクリックします。

ステップ5で、[Next: Configure Security Groups]をクリックします。


ステップ6で、[Assign a security group]オプションから[Select an existing security group]をクリックし、以前に更新した[default]セキュリティグループを選択します。 [Review and Launch]をクリックして次の手順に進みます:

ステップ7(レビューインスタンス起動)セクションで、[Launch]をクリックします:



次に、作成されるインスタンスへの接続用のキーペアを選択するように求められます。 このステップでは、先ほど作成したキーペアを選択し、「Launch Instances」を確認してクリックします。

 

この新しく作成されたインスタンスが起動します。 [Launch Status]画面で[View Instances]をクリックします。

Instances」セクションに戻り、新しく作成されたインスタンスを選択し、その名前を更新します:

 

Linuxインスタンスのインスタンス化

このセクションでは、Linuxインスタンス(Host-1)の作成について説明します。

 

EC2 Dashboard」内から「Instances」をクリックしてから「Launch Instance」をクリックします。

 

ステップ1で、以下のように「Amazon Linux AMI (free tier)」を選択します。 [Select’]をクリックします。


 

ステップ2で、[General Purpose T2.Micro]が選択されていない場合はそれを選択し、[Next: Configure Instance Details]をクリックします:

ステップ3で、 ‘Network‘で ‘VPC-1’を選択し、 ‘Subnet‘で’10.1.11.0/24 ‘を割り当てます。

 

下にスクロールし、Host-1のあらかじめ定義された「Host-1-Eth0」インターフェースを選択し、「Next: Add Storage」をクリックします:

 

ステップ4でデフォルトでそのまま進み、「Next: Add Tags」をクリックします。 ステップ5もデフォルトで進み、[Next: Configured Security Groups]をクリックします。 ステップ6で、[Assign a security group]オプションから[Select an existing security group]をクリックし、以前に更新した[default’]セキュリティグループを選択します。 [Review and Launch]をクリックして次の手順に進みます:

ステップ7(レビューインスタンス起動)セクションで、[Launch]をクリックします:

次に、作成されるインスタンスへの接続用のキーペアを選択するように求められます。 このステップでは、先ほど作成したキーペアを選択し、「Launch Instances」を確認してクリックします:

 

この新しく作成されたインスタンスが起動します。 [Launch Status]画面で[View Instances]をクリックします:

 

Instances」セクションに戻り、新しく作成されたインスタンスを選択し、その名前を更新します:



 

vEOSルータ用Elastic IPの設定

インターネット経由の到達可能性のためのパブリックIPが割り当てられていないため、作成されたばかりのvEOS ルータインスタンスは、インターネットから接続できません。 これらのインスタンスへの接続を実現する2つの方法があります:

 

  1. インスタンス化プロセス中にパブリックIPを自動的に割り当てます。 このIPはパブリックIPアドレスプールから割り当てられます。 通常、パブリックIPアドレスは、インスタンスが停止または終了するまでインスタンスに関連付けられます。 また、複数のインタフェースを割り当て、あらかじめ定義されたインタフェースを利用する場合には、パブリックIPを割り当てることができなくなるため、以下の2番目のオプションを使用します。

  1. このパブリックIPアドレスは永続的に関連付けられ、明示的に解放される必要があるため、代わりにElastic IPアドレス(EIP)を使用します。

 

このセクションでは、Elastic IPを作成し、vEOSルータに関連付けを行います。 このElastic IPを、インターネットから繋がるようにvEOS RouterインスタンスのETH2インターフェイスにマッピングするように設定します。

 

EC2 Dashboard‘内から ‘Elastic IPs‘をクリックし、次に ‘Allocate new address‘をクリックしてください:

 

次の画面で[Allocate]をクリックします。 AWSは次のようにElastic IPを自動プロビジョニングします。 ‘Elastic IPs‘セクションに戻るには、 ‘Close‘をクリックしてください:

作成した ‘Elastic IP‘を選択し、 ‘Actions‘ドロップダウンメニューをクリックし、 ‘Associate address‘を選択してください:

 

次に、 ‘Resource Type‘として ‘Network Interface‘を選択し、 ‘Network Interface‘ドロップダウンメニューをクリックし、 ‘vrouter‘をフィルタとして入力します。 名前に ‘vrouter‘があるすべてのプライベートIPが表示されます。 下記のように ‘eni-3be8f767’ / ‘vRouter-1-ETH2‘を選択してください。 :VNI IDは設定ごとに異なります。

 

次に、以下のように、ドロップダウンメニューからそのインターフェイスの「Private IP」を選択します:

 

Reassociation‘オプションをチェックし、 ‘Associate‘をクリックしてください。 これにより、次の ‘Elastic IP‘が作成されます:

 

ルーティングテーブルの更新

10.1.1.0/24および10.2.1.0/24ネットワークへの到達可能性について、10.1.1.0/24サブネットのルーティングテーブルを更新します。 これは、GREトンネルの送信元と宛先の到達可能性に必要であり、この設定全体の鍵です。

 

Services」ドロップダウンメニュー(左上)をクリックし、「VPC」を選択して「VPC Dashboard」に移動します:



 

VPC Dashboard‘から ‘Route Tables‘をクリックし、検索ボックスに10.1.1.0/24と入力します。 ルーティングテーブルを選択し、[Routes]タブをクリックし、[Edit]をクリックします。 以前に定義したVPCピアリング接続として ‘Target’を使用して10.100.1.0/24と10.2.1.0/24のルートを追加します。 [Save]をクリックします。

 

ルートを更新したら、これらのルートの「Status」が「Active」として表示されることを確認します。

 

10.1.1.0/24に対応する10.100.1.0/24のルートが既に追加されており、これらのルートの「Status」を「Active」として以下に示しています。

 

ここでは、10.1.11.0/24サブネットのルーティングテーブルを更新し、インターネットとの間の到達可能性を確認します。 これにより、SSH経由でインターネットからvRouter-1インスタンスへのアクセスが可能になります。 また、10.100.11.0/24の宛先サブネットのルートを追加します。

 

VPC Dashboard」から「Route Tables」をクリックし、検索ボックスに10.1.11.0/24と入力します。 ルーティングテーブルを選択し、[Routes]タブをクリックし、[Edit]をクリックします。 前に定義したインターネットゲートウェイを ‘Targett’に使用して ‘0.0.0.0/0’のルートを追加します。 [Save]をクリックします。:

 

‘10.100.11.0/24 ‘のルートを追加し、’ Target ‘セクションに’ vRouter ‘と入力します。ドロップダウンメニューには以下のようなオプションが表示されます。 「vRouter-1-ETH2」事前定義済みインターフェイスを選択します。 [Save]をクリックします。

 

 

「Status」が「Active」であることを確認します。これは、ENIが起動して到達可能であることを示しています。

‘10.100.11.0/24 ‘に、以下に示すTransit-vRouterのETH2を指す’10.1.11.0/24’に対応する ‘Active’ルートがあることを確認します。

 

vEOSルータへの接続

Services」ドロップダウンメニュー(左上)をクリックし、次に「EC2」を選択すると、次の「EC2 Dashboard」に移動します。

 

EC2 Dashboard」から「Instances」をクリックし、次に「vRouter-1」インスタンスを選択します。 下記の説明セクションで、「eth1」をクリックし、Elastic IPを見つけます:

 

先ほどArista-vEOS-Router.pemキーを認証エージェントに追加しているので、キーファイルを指定せずに直接vRouter-1 EC2インスタンスにアクセスできます。 ‘ssh-add -l‘を実行すると、インストールされているすべてのキーが一覧表示されます。 確認できれば、単に ‘ssh ec2-user@35.182.166.183‘を発行してvRouter-1インスタンスに接続します。

 

‘-A’オプションを使用してLinuxインスタンスSSHをvEOS Routerインスタンス(vRouter-1)に接続すると、プライベートキーファイルを指定せずにLinuxインスタンスに接続できます。 たとえば、 – ‘ssh -A ec2-user@35.182.166.183‘となります。 注: ‘-A’オプション付きのSSHは、認証エージェント接続の転送を有効にします。

 

vRouter-1インスタンスに接続したら、このコマンドを発行してLinuxインスタンスに接続します – ‘bash ssh ec2-user@10.1.11.10‘:

 

VPC-1のLinuxインスタンスとTransit-VPCのLinuxインスタンスに接続します。 以下に示すように、相互にpingを開始することによって、相互に到達可能性をテストします。

 

 

まとめ

vEOS ルータインスタンスとLinuxインスタンスとともに、すべてのコンポーネントを含むVPCを正常にデプロイしました。 VPC-1のLinuxインスタンスからvEOSルータインスタンスを通過するTransit-VPCへの接続を正常にテストできました。

vEOSルータを活用することで、一貫性あるマルチクラウドのアーキテクチャと運用アプローチで、ハイブリッドクラウドの構築が可能となります。

付録

Transit-vRouter

vRouter-1

%EOS-STARTUP-CONFIG-START%

!

hostname vRouter-Transit

!

bfd interval 500 min_rx 500 multiplier 3 default

!

interface Ethernet1

description MGMT-Int_AND_To-Transit-VPC

mtu 9001

no switchport

ip address 10.100.1.6/24

!

interface Ethernet2

mtu 9001

no switchport

ip address 10.100.11.6/24

!

interface Tunnel1

description <to-vRouter-1>

mtu 8973

ip address 10.0.0.0/31

tunnel source 10.100.1.6

tunnel destination 10.1.1.6

tunnel key 101

!

ip route 0.0.0.0/0 Ethernet2 10.100.11.1

ip route 10.1.1.0/24 Ethernet1 10.100.1.1

!

ip routing

!

router bgp 65100

router-id 10.100.1.6

neighbor transit-routers peer-group

neighbor transit-routers fall-over bfd

neighbor transit-routers maximum-routes 12000

neighbor 10.0.0.1 peer-group transit-routers

neighbor 10.0.0.1 remote-as 65101

network 10.100.11.0/24

!

%EOS-STARTUP-CONFIG-END%

%EOS-STARTUP-CONFIG-START%

!

hostname vRouter-1

!

bfd interval 500 min_rx 500 multiplier 3 default

!

interface Ethernet1

description MGMT-Int_AND_To-Transit-VPC

mtu 9001

no switchport

ip address 10.1.1.6/24

!

interface Ethernet2

mtu 8973

no switchport

ip address 10.1.11.6/24

!

interface Tunnel1

description <to-Transit-vRouter>

mtu 8973

ip address 10.0.0.1/31

tunnel source 10.1.1.6

tunnel destination 10.100.1.6

tunnel key 101

!

ip route 0.0.0.0/0 Ethernet2 10.1.11.1

ip route 10.100.1.0/24 Ethernet1 10.1.1.1

!

ip routing

!

router bgp 65101

router-id 10.1.1.6

neighbor transit-routers peer-group

neighbor transit-routers fall-over bfd

neighbor transit-routers maximum-routes 12000

neighbor 10.0.0.0 peer-group transit-routers

neighbor 10.0.0.0 remote-as 65100

network 10.1.11.0/24

!

%EOS-STARTUP-CONFIG-END%

Follow

Get every new post on this blog delivered to your Inbox.

Join other followers: