• VM Tracer configuration on a layer 2 switch

 
 
Print Friendly, PDF & Email

Introduction

There are many network architectures, which include a separate network for out-of-band management. All Arista switches come with at least one designated management interface that is VRF-aware. When VM Tracer is configured on an Arista switch, by default, vCenter communication will be sourced from the management interface. There are situations where a layer 2 switch has the management interface configured in a separate VRF, not reachable from the vCenter network segment. 

Objective

Create reachability to vCenter from layer 2 switches that have the management interface configured in a separate VRF, not reachable from the vCenter network segment. 

Prerequisites

  • Proper VM Tracer configuration should be in place 
  • A VLAN that is reachable to/from vCenter is extended to the layer 2 switch

Solution

Assuming the prerequisites are met, first trunk the VLAN from the L3SPINE to L2LEAF1 and then configure a VLAN interface on L2LEAF1 from the VLAN that has been extended. This will then generate a valid source address that vCenter can be reached from:

L3SPINE#config t
L3SPINE(config)#interface ethernet 1
L3SPINE(config-if-Et1)#switchport mode trunk
L3SPINE(config-if-Et1)#switchport trunk allowed vlan 10
L2LEAF1#sh run int management 1
interface Management1
 vrf forwarding MGMT
 ip address 192.168.0.14/24
L2LEAF1#sh run section vmtracer
interface Ethernet2
 vmtracer vmware-esx
!
vmtracer session test
 url https://10.76.8.40/sdk
 username root
 password 7 y5BlQXAUxQWJ+MkzwWsatg==
L2LEAF1#ping 10.76.8.40
connect: Network is unreachable
L2LEAF1#config t
L2LEAF1(config)#interface ethernet 1
L2LEAF1(config-if-Et1)#switchport mode trunk
L2LEAF1(config-if-Et1)#switchport trunk allowed vlan 10
L2LEAF1(config-if-Et1)#vlan 10 L2LEAF1(config-vlan-10)#interface vlan 10
L2LEAF1(config-if-Vl10)#ip address 10.76.8.2/24 L2LEAF1(config-if-Vl10)#ping 10.76.8.40 PING 10.76.8.40 (10.76.8.40) 72(100) bytes of data. 80 bytes from 10.76.8.40: icmp_req=1 ttl=64 time=96.6 ms 80 bytes from 10.76.8.40: icmp_req=2 ttl=64 time=40.3 ms 80 bytes from 10.76.8.40: icmp_req=3 ttl=64 time=36.7 ms 80 bytes from 10.76.8.40: icmp_req=4 ttl=64 time=36.5 ms 80 bytes from 10.76.8.40: icmp_req=5 ttl=64 time=35.1 ms --- 10.76.8.40 ping statistics --- rtt min/avg/max/mdev = 35.154/49.080/96.621/23.833 ms, ipg/ewma 87.127/71.922 ms

Conclusion

When VM Tracer is configured on a layer 2 switch that has its management interface in a different VRF, either the VRF has IP connectivity to vCenter or the solution listed above must be implemented.

 

Follow

Get every new post on this blog delivered to your Inbox.

Join other followers: